Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the output after sudo apt-get -f install

The following packages will be upgraded:
  libboost1.49-dev
1 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
21 not fully installed or removed.
Need to get 0 B/9,182 kB of archives.
After this operation, 24.6 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 580974 files and directories currently installed.)
Preparing to replace libboost1.49-dev 1.49.0-3.2ubuntu1 (using .../libboost1.49-dev_1.49.0-4_i386.deb) ...
Unpacking replacement libboost1.49-dev ...
dpkg: error processing /var/cache/apt/archives/libboost1.49-dev_1.49.0-4_i386.deb (--unpack):
 trying to overwrite '/usr/bin/inspect', which is also in package libboost1.53-tools-dev 1.53.0-6+exp3ubuntu8
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.49-dev_1.49.0-4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Run the following commands on terminal,

sudo dpkg -P libboost1.53-tools-dev
sudo apt-get -f install
share|improve this answer
    
I have run sudo apt-get -f install and still have same error –  manolovaza Jan 31 at 10:15
    
Post the output of 'sudo apt-get -f install' –  Avinash Raj Jan 31 at 10:41
    
The following packages have unmet dependencies: libboost-chrono1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed libboost-date-time1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed libboost-filesystem1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed libboost-graph-parallel1.49-dev : Depends: libboost1.49-dev (= 1.49.0-4) but 1.49.0-3.2ubuntu1 is installed –  manolovaza Jan 31 at 11:11
    
try sudo aptitude -f install. –  Avinash Raj Jan 31 at 11:13
    
I am not able to paste all the code but here is something more that keeps appearing: Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: collada-dom-dev collada-dom2.4-dp-base collada-dom2.4-dp-dev freeglut3-dev g++-4.7 hddtemp html2text libassimp-dev libassimp3 libcf0 libcolumbus0-0 libcolumbus0-0-common libcppunit-1.12-1 libcppunit-dev libcurl4-openssl-dev libdns95 libeigen3-dev libfltk1.1 libfltk1.1-dev libfreeimage-dev –  manolovaza Jan 31 at 11:15
show 19 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.