Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So my wifi was disabled (I couldn't select the "enable wifi" option) and wouldn't automatically connect to wifi sometimes. I ran this command after reading that it did the trick for someone

sudo modprobe -rv wl
sudo apt-get remove --purge bcmwl-kernel-source
sudo modprobe -v brcmsmac

but now the option is gone altogether and it still won't connect! Any suggestions?

share|improve this question
    
Try with the applications and the drivers in this answer –  user224082 Dec 20 '13 at 3:30

1 Answer 1

Have you check /etc/network/interfaces setting. I sometime lost enable wifi option by editing this file for some reason.

But you can use:

sudo ifup

For me wireless interface is wlan0 then I run.

sudo ifup wlan0

Issue ifconfig to list all your network interfaces.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.