Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I recently bought a USB wifi adapter for my new desktop computer. It's a D-link DWA-160 A2. From the start it didn't want to work at all, but after unplugging and then plugging it back in, it seems to work.

However, my browsing is painfully slow. NetworkManager reports the connection to be at around 78-85% signal strength, which seems perfectly acceptable.

Is there anything I can do to make it faster? I'm dual booting with Windows 7, where it seems to work fine, so I'm guessing that the problem occurs because of crappy drivers.

share|improve this question

2 Answers 2

What is the chipset of D-link DWA-160 A2 ? Googling a bit, it seems to be an Atheros chipset. If it happens to be an AR9285, you are using the ath9k driver and might be hitting bug 518818 (on launchpad)

Using latest compat-wireless solved the issue for me, so you can try it:

1) download compat-wireless 2010-09-12.tar.bz2 from

2) unpack it

3) make

4) sudo make install

This should do the trick (if your problem is the one I suppose of course)

share|improve this answer
thanks!! this helped me a lot! –  user11346 Feb 23 '11 at 15:35

This solved my slow conection problem with DWA-160 A2 and with Lucid: Upgrade driver from ar9170usb to carl9170

here are instructions:

share|improve this answer
Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... –  Fabby Sep 29 at 20:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.