Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Even after doing the steps from Ubuntu for fixing the going out of suspend problem with Nvidia cards, I still can make it work. When I wake up from suspend I get just black screen with blinking cursor and that's it.

Below I'm pasting the steps I followed:

Suspend/Hibernation

If you use an old Nvidia driver, hibernation & suspend may not work, there is a workaround however.

  • We need to edit xorg.conf, open a terminal and enter the following command:

    gksudo gedit /etc/X11/xorg.conf
    
  • In the section called Section "Device" add Option "NvAGP" "1", you should end up with something like this:

    Section "Device"
    Identifier     "my id"
    Driver         "my dr"
    VendorName     "my vendor"
    BoardName      "my board name"
    Option         "NvAGP" "1"
    EndSection
  • Blacklist the intel_agp module from being loaded by the kernel. This is done by editing blacklist.conf, open a terminal and type:

    gksudo gedit /etc/modprobe.d/blacklist.conf
    

    Then add the following line:

    blacklist intel_agp
    
  • Reboot your system.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.