Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The time have risen from 20-25 sec in Meerkat to 35 sec in Natty. I do not know if it is ureadahead but made a bugreport of it in launchpad. I tried Fedora shortly before installing Natty. They use systemd instead of upstart and didn't have this slow boot.

In a dmesg this jump shows up:

[    3.087606] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   15.292831] <30>udev[308]: starting version 167

How could it be that booting got so much worse? I also have a "black screen" much longer before Plymouth splash starts in Natty then in Meerkat. Could it be the famous kernel regression?

share|improve this question
+1 I have the same problem, and I also saw it in other people's posted dmesg output. What on earth is it doing between seconds 3 and 20?: [ 3.106155] EXT3-fs (sda2): mounted filesystem with ordered data mode [ 20.726183] Adding 10239996k swap on /dev/sda3. Priority:-1 extents:1 across:10239996k [ 20.784551] udev[301]: starting version 167 – krubo May 3 '11 at 1:41
Intresting.. as you are using EXT3, i EXT4 and i have seen others with BTRFS. It doesn't seem to be the file system. – AlMehdi May 3 '11 at 2:22
I have a similar dmesg log: [ 3.413050] EXT3-fs (sda6): mounted filesystem with ordered data mode and [ 17.810635] Adding 1998844k swap on /dev/sda5. Priority:-1 extents:1 across:1998844k. Did you came any further? Do you have the link to the bug report? – Lode Sep 6 '11 at 9:11
This page from fixed my similar problem: – ringø May 2 '12 at 7:55

I set ACPI=off in grub... it worked :)

It boots in about 30 second (before that 2-3 minutes).

share|improve this answer
Have alreaady tried that.. i think that solution is for another regression than mine. Mine is just off ~20 sec. – AlMehdi Jun 7 '11 at 17:49

I would recommend:

  1. Install cryptsetup package. It doesn't harm your system, but fixes long "black screen" before Plymouth
  2. Remove and then install back ureadahead package. After that perform reboot. Check that /var/lib/ureadahead/pack file is created ~1-2 minutes after reboot.
  3. Reboot with timer now :)
share|improve this answer
Tried it but didn't solve my problem. Thanks for the suggestion though. – AlMehdi May 4 '11 at 11:16

In /lib/udev/rules.d/60-persistent-storage.rules comment this rule:

# ATA/ATAPI devices (SPC-3 or later) using the "scsi" subsystem
KERNEL=="sd*[!0-9]|sr*", ENV{ID_SERIAL}!="?*", \ SUBSYSTEMS=="scsi", ATTRS{type}=="5", ATTRS{scsi_level}"[6-9]*", \ IMPORT{program}="ata_id --export $tempnode"

Then run as root:

update-initramfs -u


share|improve this answer
Although i have a crappy DVDRW it didn't work for me.. Thanks for the suggestion. ;) – AlMehdi May 11 '11 at 22:33

I had a strangely slow boot on my freshly installed 11.04 (around a minute on a brand new computer), Then I changed the SATA-port on my DVD-drive from a 6Gb/s port to a 3Gb/s port. This change improved my boot time to 20 seconds. I'm not sure why this worked but it's certainly worth trying if your DVD drive is connected to a 6Gb/s SATA port.

share|improve this answer
My motherboard is old so that is most probably not it for me. But thanks for the proposal. I bet someone else might have this problem and get helped by it. – AlMehdi May 13 '11 at 17:12

protected by Community Oct 15 '11 at 12:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.