Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I install maas > juju > OpenStack with co-located services.

The "openstack-dashboard" charm is installed on the same node with "keystone".

All the units are up with no errors, and this is the output of juju stat

I also mapped all the hosts names at /etc/hosts.

Yet the http://openstack-dashboard/horizon 500 Internal service error`.

I got the Apache2 error.log and it's filled with python exceptions which "as a sysadmin" I cannot interpret.

How can I solve this?

share|improve this question
    
What exactly is the problem? If you can't resolve the hostname, you might need to configure DNS; otherwise, please add more detail about what you're expecting but not getting. –  fwereade Dec 19 '13 at 16:43
    
I updated the question. –  Harti Dec 20 '13 at 5:07
    
According to status output, shouldn't that be http://rm-mas-04.rmgs.labs/horizon? –  fwereade Dec 20 '13 at 7:28
    
Yes it should. yet it's not there. I tried deploying the dashboard to a fresh node yet again same thing. unbrowsable –  Harti Dec 23 '13 at 0:10
    
I've rebuilt the lab and updated the ticket. now it gives [this error] (pastebin.ubuntu.com/6621943) when I try to browse horizon. –  Harti Dec 23 '13 at 8:04

1 Answer 1

up vote 0 down vote accepted

Ok it turns out that OpenStack is not compatible with django 1.5 I've removed it and installed 1.4 and everything worked normally.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.