Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I've trid to get xrdp working on Ubutnu Server 13.10 which meant a lot of messing around with lightdm and gdm. So after giving up on xrdp i switched to vnc. I installed vnc4server purged lightdm(as i chose it over gdm) installed ubuntu desktop, and instead of seeing my desktop i get only a terminal or if trying to run either unity or gnome-session in my xstartup i get either a gray screen if the line is not commented out or a patterned screeen both with the X cursor. What could be the cause of this?



# Uncomment the following two lines for normal desktop:
# exec /etc/X11/xinit/xinitrc

gnome-session-fallback &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
#vncconfig -iconic &
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
#unity &
gnome-session --session=classic &

And my screen looks exactly like in this question :Why can't I get a working session with vnc4server Although the answer there hasn't helped in my case.

share|improve this question

why you load two gnome-session ? if you want to use gnome with vnc server on ubuntu, install these packages and use this xstartup file for gnome

# apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal

xstartup file



[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &
gnome-terminal &
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.