Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I receive the message

error: no such device: xxxxxx. grub rescue>_

I've reinstalled GRUB numerous times using a live cd, using boot repair. I can boot into my system using super grub disk 2 and I've reinstalled grub using rescatux it says the grub is intalled correctly but when I boot into my hard drive I still get the same error message this only happens with ubuntu 12.10 and up and I dont have windows installed in any other partition please help me I've tried to solve it for several days to no avail.

share|improve this question
    
I assume the checks you have done confirm UUID is correct. Some systems have issues with very large / (root) partitions. Is / over 100GB or not fully within the first 100GB of the drive? Then a smaller / or separate /boot may work. Other work arounds to easily test is to comment out the search line. As long as set root is correct partition it should boot. Another is also to change from UUID to device in linux line like root=/dev/sda1 –  oldfred Dec 18 '13 at 19:20
    
Solved it by running rescatux grub restore and changing hard drive boot order in BIOS :) Thanks –  Raven Dec 18 '13 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.