Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Well , I used both codes below , also I used dconf-editor to tweak the panel.

I Tried to set the code to one program or two , and 'all'.

But the problem is that sometimes(not always) I can't click on the sound indicator or network manager or any indicator (Except the Me menu, the messaging menu, and the shutdown menu).

  1. gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

  2. gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'YOUR_APPLICATION']"

So I want something to replace this problem please.
Any suggestion?

share|improve this question
up vote 0 down vote accepted

That "problem" is a bug, and has nothing to do with the notification area. Sometimes the indicators do not take clicks, why, I'm not 100% sure. Fortunately, there are two ways around it:

  1. You can click on an indicator that works, and then move the mouse toward the other indicator that you want, and it will open it.
  2. You can restart unity: alt+f2 - unity - enter.
share|improve this answer
Ohh I see. For the first step , yes it works. and the second worked and then return to the same issue. Ubuntu 11.04 is awesome , but this is bothering me.They will fix this bug right ? – Binarylife May 2 '11 at 17:54
@binarylie: I believe so, I would suggest adding some voice to it on launchpad (ubuntu-bug unity), your help in getting to the bottom of it would be greatly appreciated. – RolandiXor May 2 '11 at 20:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.