Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This seems to have been covered a lot before, but none of the solutions seem to help.

It's the usual getting this error message while installing.

The ext4 file system creation in partition #1 of SCSI1 (0,0,0) (sda) failed

I'm trying to install 12.04 on a brand new HDD in a reasonably old laptop though it should have plenty good enough specs. Working from a USB drive which seems to be running ok.

I've tried formatting it, repartitioning it, checking it's health with the SMART diagnostics. If exhausted the Something Else option during the installation and have tried various suggestions using gparted.

I'm reasonably tech savvy, but also reasonable new to Linux, though I have done installations before on virtual machines.

I have access to another working Windows machine, which I'm writing this on, if that's any use.

I've looked at and tried these threads and read others too:

ubuntuforums.org
answers.yahoo.com
ERROR: The ext4 file system creation in partition #1 of SCSI 1 0,0,0 sda failed

However a lot of threads seem to either run dry, or the error is cause by a faulty HDD or other such reason.

How to fix this ?

share|improve this question

1 Answer 1

Well I've got it working. Turns out there must have been something wrong with my USB image. It ran fine and didn't show any other symptoms. Decided to recreate it anyway and used different software this time to create the bootable USB stick.

With that, the install ran just fine.

Before, I used "LinuxLive USB Creator 2.8.25". The one I used this time (which worked) was "Universal-USB-Installer-1.9.5.1"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.