Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I'm very new to Ubuntu, so don't put me into dumb situations or stuff, and sorry for bad english.

My problem is that Steam App is not working for me.

It turns on pretty well and login is not lagging, but then I'm in the app, everything is like 1fps, it's impossible to do something e.g download the game, browse and chat, maybe there is a solution to fix the lag.

What I did for optimizing Ubuntu

  • Increased Performance of Dash Home
  • Changed Properly Drivers
  • Installed maybe 2~4 apps
  • Optimized more with Compiz

Pc Specifications

  • 1.73 Ghz x2 Intel CPU T2080
  • Nvidia Geforce 7600 GO
  • 2 GB RAM
  • Ubuntu 13.10
share|improve this question
    
Have you used Steam on Windows? It might be your specs, though I'm not sure. 2GB of RAM isn't the best for gaming. –  RPi Awesomeness Dec 18 '13 at 16:01
    
Yeah, I used it on windows, It worked really fine, no lag at all. Why I got minus on my comment, what the hell. I tried to be as manner as I can and somene did it, sad... :( –  Ainis Skominas Dec 18 '13 at 16:47
    
Hmm...Not sure then. That's strange. –  RPi Awesomeness Dec 18 '13 at 16:47
    
Well, at least you said something. –  Ainis Skominas Dec 18 '13 at 17:00
    
Do you have trouble with any other apps doing this (being slow and unusable?) Also, what version of Windows were you using before? –  RPi Awesomeness Dec 18 '13 at 17:01
show 10 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.