Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 13.10 x64 and have 64 and 32 bit versions of Java 6 installed. I have it configured that when running Network Connect it will run the 32 bit version and for anything else the 64 bit version.

I can get Network Connect to start when going to the site (I have x32 versions of firefox and icedtea-plugin), but right after it launches it crashes. The timer on the Network Connect will sometimes goto 00:00:01, but never to 00:00:02 before crashing.

The error report:

The crashed program seems to use third-party or local libraries:
/home/user/.juniper_networks/network_connect/libncui.so
It is highly recommended to check if the problem persists without those first.
Do you want to continue the report process anyway?

The error occurs with the 32 bit Java, not with the 64 bit. I know that libncui.so is only 32 bit, but I don't think that is the issue since I get the Network Connect GUI when it launches.

Does anyone have a fix?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I don't have a fix for your particular setup. However, The setup I described in Juniper setup on 12.04 works in 64bit Ubuntu 13.10 as well.

Steps to move from your setup to my setup:

  1. Delete the folder /home/user/.juniper_networks to start fresh.
  2. Remove all Java 6 (openjdk*). Remove 32bit Firefox, and install 64bit firefox if not installed.
  3. Install 64bit Java 7, and associated icedtea. This should be the default java.
  4. Install 32bit Java 7. No need for 32 bit icedtea. This should not be default. Juniper will find the files it needs and use it from the 64bit Firefox and 64bit icedtea.

Hope this helps

share|improve this answer
    
Thanks for the idea, I tried this, using the libnpjp2.so from the x64 and the x32 in ~/.mozzila/plugins, neither of which seemed to work. Network Connect still crashes after launching. –  sparks Dec 18 '13 at 17:43
    
You are welcome. It may be useful to delete the .juniper_networks and let juniper recreate it when you try to connect again. –  user68186 Dec 18 '13 at 19:20
    
So, I forgot to check your link, and that fixed the crashing, thanks. Note to self: it's bad to assume. –  sparks Dec 18 '13 at 20:35
    
Thanks! Could you tell me which instruction in the link fixed the crashing? I will then edit this answer to include it, so that others don't have to follow the link. –  user68186 Dec 18 '13 at 20:48
1  
It worked once I did your 64 bit instructions, removed all openjdk* and reinstalled only the openjdk-7 both the x64 and x86. Sadly though it seems like it only worked once, once that session closed, and I tried opening another (still had errors and working on those fixes too) Network Connect didn't want to stay up anymore. This occured even after a restart. I will do more bug fixing tomorrow. –  sparks Dec 18 '13 at 22:06

t's mostly a problem of your HOME-directory. It's encrypted, am I right? ;) So it is mounted with a "nosetuid" option, that prevents any SUID Operations to work as you expect them.

Solution: copy your network-connect directory somewhere else on your HDD (i.e. /opt/juniperconnect)), edit the junipernc-script to point to the new directory (called _jpath in the script /usr/local/bin/junipernc ), and then it works for me. I'm still using nc version 7.1 with Ubuntu 14.04 LTS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.