Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 13.10 x64 and have 64 and 32 bit versions of Java 6 installed. I have it configured that when running Network Connect it will run the 32 bit version and for anything else the 64 bit version.

I can get Network Connect to start when going to the site (I have x32 versions of firefox and icedtea-plugin), but right after it launches it crashes. The timer on the Network Connect will sometimes goto 00:00:01, but never to 00:00:02 before crashing.

The error report:

The crashed program seems to use third-party or local libraries:
It is highly recommended to check if the problem persists without those first.
Do you want to continue the report process anyway?

The error occurs with the 32 bit Java, not with the 64 bit. I know that is only 32 bit, but I don't think that is the issue since I get the Network Connect GUI when it launches.

Does anyone have a fix?

share|improve this question
up vote 0 down vote accepted

I don't have a fix for your particular setup. However, The setup I described in Juniper setup on 12.04 works in 64bit Ubuntu 13.10 as well.

Steps to move from your setup to my setup:

  1. Delete the folder /home/user/.juniper_networks to start fresh.
  2. Remove all Java 6 (openjdk*). Remove 32bit Firefox, and install 64bit firefox if not installed.
  3. Install 64bit Java 7, and associated icedtea. This should be the default java.
  4. Install 32bit Java 7. No need for 32 bit icedtea. This should not be default. Juniper will find the files it needs and use it from the 64bit Firefox and 64bit icedtea.

Hope this helps

share|improve this answer
Thanks for the idea, I tried this, using the from the x64 and the x32 in ~/.mozzila/plugins, neither of which seemed to work. Network Connect still crashes after launching. – sparks Dec 18 '13 at 17:43
You are welcome. It may be useful to delete the .juniper_networks and let juniper recreate it when you try to connect again. – user68186 Dec 18 '13 at 19:20
So, I forgot to check your link, and that fixed the crashing, thanks. Note to self: it's bad to assume. – sparks Dec 18 '13 at 20:35
Thanks! Could you tell me which instruction in the link fixed the crashing? I will then edit this answer to include it, so that others don't have to follow the link. – user68186 Dec 18 '13 at 20:48
It worked once I did your 64 bit instructions, removed all openjdk* and reinstalled only the openjdk-7 both the x64 and x86. Sadly though it seems like it only worked once, once that session closed, and I tried opening another (still had errors and working on those fixes too) Network Connect didn't want to stay up anymore. This occured even after a restart. I will do more bug fixing tomorrow. – sparks Dec 18 '13 at 22:06

I had this problem, too. I followed instructions from Juniper's site and . After reading logs in .juniper_networks/, I found out that the sh script to open NC.jar opens xterm. In order to fix this, you have to install xterm:

sudo apt-get install xterm

This will for sure make sure that sremote is actually working on Ubuntu 14.04 and Linux Mint 17. I've seen it work on some Ubuntu computers though... I am using webupd8team's java oracle 8 as the default and manually installed java oracle 8 u25 32-bit manually from the oracle site.

EDIT 2: A fresh Ubuntu 15.04 and the latest 32-bit oracle java 8 works straight out of the box!!!

share|improve this answer
This solved the original problem of Juniper Network Connect (8.0-6-Build32195) crashing for me directly after starting - I'm using 32 bit Firefox & 32 bit JRE. – Paul Caheny Apr 21 '15 at 20:16

t's mostly a problem of your HOME-directory. It's encrypted, am I right? ;) So it is mounted with a "nosetuid" option, that prevents any SUID Operations to work as you expect them.

Solution: copy your network-connect directory somewhere else on your HDD (i.e. /opt/juniperconnect)), edit the junipernc-script to point to the new directory (called _jpath in the script /usr/local/bin/junipernc ), and then it works for me. I'm still using nc version 7.1 with Ubuntu 14.04 LTS.

share|improve this answer

I had the exact same problem and it was due to HOME directory being encrypted, just like hmayag pointed out. Copying the whole $HOME/.juniper_connect out to an unencrypted place solved the issue (and editing the _jpath variable in the to point to the new location). Mine is Ubuntu 14.04 64-bit, using Oracle JRE 1.8.0_60 (32-bit Java 8 runtime env).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.