Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Am on 11.04. When I close my laptop lid (NVIDIA graphics - HP Pavilion) it goes onto sleep mode. But when I reopen it, instead of resuming onto the password prompt, it shows me a screen of random blocky colours - typically largely yellow. I have to do a hard reset to restart the PC. Here is an image I took of the problem:

enter image description here

Would file it on launchpad but not sure if it is a bug or isolated.

Thanks for any help.

share|improve this question
add comment

4 Answers

Does that pointer move ? Is numlock light blinking ? Are you running unity or gnome ?

here is some howto for debugging problems with suspend

https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume

share|improve this answer
    
The cursor does move. The numlock light doesn't blink but will switch on or off if I press the button. I am running unity. –  wman2 May 2 '11 at 14:56
    
so, it is not problem with kernel panic. System resumes, but there is problem either with graphic driver or unity. Can you try running classic gnome panel session ( on login choose ubuntu classic ) ? –  Denwerko May 2 '11 at 15:01
add comment

I just solved this for myself. I was having the same behavior, plus issues with Twinview. I found I was running the version 173 of the Nvidia driver, not the current recommended version.

My setup:

  • Dell Latitude e6400
  • Nvidia Quadro NVS 160M
  • Using Twinview (but reproduces without Twinview too)

First, execute the following command:

~$ cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86 Kernel Module 270.41.06 Mon Apr 18 14:54:25 PDT 2011 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)

If you see 173.x.x or 185.x.x or something you are out of date.

  1. Open the Unity Dash (or something like System/Admininistration in Gnome)
  2. Type "Additional Drivers" and select the app (or find the menu item in Gnome)
  3. It should bring up a couple of entries for your Nvidia card. Install the "current version".
  4. Reboot your machine

Things perform better for me after doing this, but not perfect.

Also, I found that I could also avoid this problem by logging in to the "Ubuntu Classic (no effects)" window manager. If you are really stuck, that may be your best option.

share|improve this answer
add comment

For me the suspend/resume works again with nVidia GO 7300 with this workaround mentioned here: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/728745/comments/73

  1. Install libgl1-mesa-dri-experimental.

  2. maybe you have to update your system with the x-swat ppa (ppa:ubuntu-x-swat/x-updates)

  3. Open the terminal and type the following commands:

    sudo update-alternatives --config gl_conf

and select the alternative provided by mesa.

sudo ldconfig
sudo update-initramfs -u
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf_old

You also have to install the nouveau driver.

and restart your computer. After that I was able to suspend/resume my machine without graphic problems.

Hope this will help other.

Greetings.

share|improve this answer
    
I have already downgraded to the 173 driver because on the current one, I had the problem where if I had more than 2 windows open at once, any new windows would turn blank white. Why can't they just release an update? –  wman2 May 14 '11 at 13:25
add comment

If your video card is Agp, then the solution is to install the current Nvidia drivers from the Nvidia site and add the Option "NvAgp" "1" to section "Device" in /etc/X11/xorg.conf.

This forces the Nvidia driver to use Nvidia's built in Agp handling rather than Agpgart which nouveau is probably using.

Details

Download Nvidia's latest driver for your card.

Let the Nvidia driver installation do the blacklisting of the Nouveau driver when running the Nvidia driver install.

Copy the Nvidia driver file to /home/$USER/Downloads.

Using Terminal, update the headers:

sudo apt-get install linux-headers-generic

then log in as root using your password in tty1 (Ctrl + Alt+ F1), then cd /home/$USER/Downloads, then stop xserver: /etc/init.d/mdm stop, then run Nvidia driver install: sh Nvidiadriverfile.sh

I used sh NVIDIA-Linux-x86-173.14.37-pkg1.run.sh then for Agp cards.

After reboot edit the xorg.conf file:

sudo gedit /etc/X11/xorg.conf

and add Option "NvAgp" "1" to section "Device" to fix wake up from sleep problems for Agp cards (wake up from sleep problems also happen with the nouveau driver for Nvidia Agp cards).

Then install nvidia-settings utility.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.