Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I attempt to update in apt-get or aptitude, I get the following error:

E: GPG error: http://packages.medibuntu.org saucy InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

Medibuntu was a project by Ubuntu that contained 'closed' packages. It has since been closed, and the server shut down. Removing the packages seems to be advised.

There are several similar questions open on askubuntu and elsewhere, but none are quite the same error, and the solutions have not helped.
I've detailed the steps taken and the results. After each step I ran sudo apt-get update, and received the same err.

  1. Deleted all references to Medibuntu in /var/lib/apt/lists
  2. apt-key list: Does NOT show the Medibuntu key.
    1. Many threads refer to the serial of the Medibuntu key as being 2EBC26B60C5A2783.
      Not sure how to confirm that.
  3. Attempted both techniques for adding the key that have been described here and here. Neither works. After both, apt-key list does not include Medibuntu, update crashes.
    1. sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring
      Could not find package or ppa
    2. sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 2EBC26B60C5A2783
      Nothing changed.
  4. Removed dpkg lock and all HTML files: sudo rm -f /var/lib/dpkg/lock
  5. Removed all sources that are not from this release, and all things listed in dpkg/status as being dependant on Medibuntu.
  6. Attempted to purge Medibuntu (Tried with aptitude apt-get and dpkg -r)
    In each case it failed with the message that medibuntu and medibuntu-keyring are not installed.
  7. Tried using keyserver.pgp.com as a keyserver.
  8. Added the key using gpg (and similarly, here):
    gpg --keyserver keyserver.ubuntu.com --recv-key 2EBC26B60C5A2783
    gpg -a --export 2EBC26B60C5A2783 | sudo apt-key add -
    Medibuntu is now listed through apt-key list, but still unable to run update (same err as before).
    Running sudo apt-key adv... (step 3.2) doesn't help.
  9. Tried to remove the keys using apt-key del. Removed keys, back to square one. Update still not working
  10. Tried using wget to get an updated medibuntu list file, and tried to reinstall medibuntu-keyring.
    Links are dead, package not found.
  11. Have found alternate list of keyservers here. Doesn't look like it will make a difference, as the key is listed in apt-key list. The PPA and package linked from here are no more.
  12. Checked and updated ownership of gpg files as suggested here. Didn't change anything.
  13. Ran sudo apt-get clean, and rebooted many times as I went along.

Some unrelated links for the mods who click "duplicate" on impulse: here, here, and here

I would generate new list files from here but I worry I might have some installed packages that will not therefore be updated, posing a security risk.

Please help, being unable to update is a serious issue.

share|improve this question

marked as duplicate by Takkat, Braiam, BuZZ-dEE, blade19899, karel Dec 19 '13 at 12:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Mint is not an official Ubuntu derivate, hence this question is off topic here. Apart from that: did you amongst all you tried also remove the Medibuntu entry in your /etc/apt/sources.list? –  Takkat Dec 18 '13 at 13:51
    
Removed Medibuntu entry - used grep, and removed every reference to medibuntu from /etc/apt/ –  SamGoody Dec 18 '13 at 13:58
    
I referenced the "possible duplicate" in my question (#3), and explained how the answer which helped there (purging the existing repo) won't help in my question (no references to the repo exist). The question itself is quite different as well, I encourage you to actually read both. –  SamGoody Dec 18 '13 at 19:47
    
Referenced it in #6, not #3. Nonetheless, there should be negative points for the mod who marks a question as duplicate without bothering to understand both questions first. (Will I be down-voted for suggesting that?). –  SamGoody Dec 18 '13 at 19:59
    
Do you realize that nobody here owes you anything? Please keep polite. –  guntbert Dec 18 '13 at 21:27

1 Answer 1

up vote 0 down vote accepted

Open Synaptic Package Manager select settings then Repo's then other software then untick anything in the list starting with medibuntu then close and refresh the list by updating cache.

enter image description here

share|improve this answer
1  
You, I love. Hours and hours of wasted time... Thanks! –  SamGoody Dec 18 '13 at 14:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.