Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using an HP Envy 14t Laptop which had Windows 8.1 pre-installed in it, it has its recovery files in an SSD. I installed Ubuntu 12.04.3 following the instructions provided here:

Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported)

I could not disable QuickBoot/FastBoot, as I dont have the option in the BIOS. After the installation finishes the laptop boots straight into Windows 8.1, so as mentioned in the instructions, I boot up Ubuntu using a LiveUSB and run boot-repair, but boot-repair gets stuck at the point where it says: Scanning systems (os-prober). This may require several minutes.

I wait for 45 minutes or so, but it does not proceed any further. So just out of curiosity I quit boot-repair and run os-prober in the terminal and this is what prints out:

ubuntu@ubuntu:~$ sudo os-prober
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
/dev/sdb5:Windows Recovery Environment (loader):Windows:chain
/dev/sdb6:Ubuntu 12.04.3 LTS (12.04):Ubuntu:linux

And sda is the LiveUSB that Im using. sdb is the hard drive, and sdc is the SSD(which has Windows Recovery files).

share|improve this question

The issue you have seems to be secure boot related. In your BIOS, try setting the 'secure boot' option to disabled. It's probably located under the 'Boot' menu. Be sure to set your CSM option to enabled (some manufacturers will call this EFI/Legacy mode). Boot repair should be able to pick up from there. The windows secure boot option will prevent any other form of application/boot sequence from interfering with the Windows boot, which makes the system automatically boot windows.

Be sure to set your main boot device to the hard disk you have the bootloader (GRUB?) installed on.

Further documentation about Secure Boot can be found here:

share|improve this answer
I first disabled Fast Startup from Windows, then I disable Quickboot/Fast boot, and Intel Smart Response Technology/Intel Rapid Storage Technology from BIOS and then Installed Ubuntu. Then I enabled Legacy mode and tried Boot-repair... Still no remedy. My boot order stands as this: 1. UEFI Boot Order: 2. USB Diskette on Key/USB Hard Disk 3. OS Boot Manager 4. USB CD/DVD ROM Drive ! Network Adapter Legacy Boot Order: 1. Notebook Hard Drive 2. USB Diskette on Key/USB Hard Disk 3. USB CD/DVD ROM Drive 4. ! NEtwork Adapter – Rifaz Nahiyan Dec 18 '13 at 12:57
Try setting the hard disk (with grub) to the highest priority. Usually you want to avoid the windows boot loader to come first, as it will probably still stop you from booting anything but windows. – OxySocks Dec 18 '13 at 13:40
I dont have the option of Hard disk, in the UEFI Boot Order... :/ – Rifaz Nahiyan Dec 18 '13 at 14:19
Try setting the boot mode to EFI only, and the harddisk as first in the EFI boot sequence. You will probably have to re-run boot repair. I know, it's tedious. – OxySocks Dec 18 '13 at 14:53
Enabling CSM/legacy boot mode is likely to just cause more problems. On a multi-boot computer, it's usually easiest to have all the OSes booting in the same mode (BIOS/CSM/legacy or EFI/UEFI). Windows 8/8.1 comes pre-installed to use EFI mode, so that's what should be used to install Linux. – Rod Smith Dec 18 '13 at 17:01

First, it's important that you disable the Windows Fast Startup feature, as described here (among many other places). Note that this is not the same as the "fast boot" feature present in many EFIs; this is a Windows feature that turns a shutdown operation into a suspend-to-disk operation. The result is often filesystem corruption and problems installing or using boot loaders. It's possible that this feature is the cause of the I/O errors noted in the question.

If that doesn't help, try the USB flash drive or CD-R version of my rEFInd boot manager. If it enables you to boot both Linux and Windows, try installing it from Linux; it should then take over as the primary boot manager, bypassing GRUB. You'll need to either disable Secure Boot (which you say you've already done) or jump through some extra hoops.

share|improve this answer
Thank you for the reply. I'll try this tomorrow right when I'll get my pendrive back. I disabled Fast Startup from Windows, but could not find the option for FastBoot in my BIOS. Should I try using rEFInd from a live environment? – Rifaz Nahiyan Dec 19 '13 at 19:05
rEFInd is a boot loader -- it runs before any OS, whether it's installed on the hard disk or a "live" system. – Rod Smith Dec 20 '13 at 22:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.