Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a 1TB HDD partitioned as follows

2 primary partitions 100MB created by windows7 and a 50GB I used as my C drive (which contained my win7 OS) Remaining full an extended partition
That extended is divided into
100 GB - NTFS
250 GB - EXT4
~580GB(approx) - EXT4
~17GB(approx) - EXT4 Ubuntu was installed in this partition ( no swap)

I have done the most stupid thing, deleted the 2 primary partition to update to windows 8 Obviously I lost my extended partition which now shows as un allocated space. The strange thing is that my ubuntu installation was intact i could boot into it.

I ran test disk it was able to detect 100GB and 580GB partitions; but failed to detect the 250 GB partition which is the most important one for me.

Ran a deeper search. Detected all the partitions but there was double entry for some partitions

changed to 250GB partition to primary in testdisk to recover it. But it fails to mount now.

At this point I have made a copy of the whole HDD with ddrescue.

Tried e2fsck on that 250GB partition shown a lot of errors, after repairing mounted it. There was nothing in that partition except the lost+found folder; but the drive properties shows ~70GB occupied (In fact I had data almost to full).

Can some one help me to recover it? It's much important to me

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.