Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I met a strange problem. When I use LiveCD to install ubuntu 12.04 LTS, I was able to connect to Internet through wired connection, choosing "Try Ubuntu".

But when I installed it, it could not connect:

ifconfig -a shows that eth0 does not have inet address

I added:

auto eth0
iface eth0 inet dhcp

to interfaces, then restart networking, it says:

Reconfiguring network interfaces...
Failed to bring up eth0

I tried to set static ip, but still no connection.

I tried to delete 70-persistent, but still no connection.

I tried to reinstall network driver, but still no connection.

What can I do? Thanks.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.