Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I recently bought a Toshiba Satellite P50, I tried installing Ubuntu 12.04.3 and 13.10 alongside Windows 8.1.

If I disable Secure Boot, but leave the UEFI mode on, I can get to the screen that asks If I want to try Ubuntu. When I select that option the screen just goes black and nothing happens.

I'm only able to load Ubuntu from a usb when the Secure Boot and the UEFI mode are both enabled. But, after I install it, the computer loads only into Windows. I ran the boot-repair after from the usb, after disabling Secure Boot, and it told me that I should disable Secure Boot, but when I did I was again unable to load it from the usb.

Thanks for taking the time to read this. Any help or suggestions with would be greatly appreciated!!

share|improve this question

marked as duplicate by Thomas W., Eric Carvalho, Braiam, karel, Seth Dec 18 '13 at 21:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Several suggestions here. Seems to be an issue with NIC but then you will only have wifi. Toshiba Satellite P50 model number: P50-A-01E Haswell processor ubuntuforums.org/showthread.php?t=2163854 –  oldfred Dec 18 '13 at 5:30
add comment

1 Answer 1

If you did your install while secure boot was enabled, need to run boot-repair while secure-boot is enabled.

share|improve this answer
    
Thanks for the quick response. If do that, will it set up the GRUB bootloader with secure boot? My concern with running the boot-repair on secure boot was not being able to get back into windows after. –  user226538 Dec 18 '13 at 3:47
    
It will likely auto-detect windows and add a boot option form the Grub2 menu (I'm not sure I never set up windows). If not, no worries as Ubuntu's UFEI won't overwrite Windows UFEI informaton, so you'll still be able to select the UFEI Windows loader. –  virtualxtc Dec 18 '13 at 3:51
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.