Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install ubuntu12.04LTS.

Not being able to install ubuntu using wubi. after running wubi and selecting the drive and passwords etc. , the download starts but following error is displayed:

An error occured:

IOError: <urlopenerror (7,'getaddrinfo failed')>
For more information please see the logfile
  c:\docume~1\owner\locals~1\temp\wubi-12.04.3-rev279.log

How to solve this error?Please help me on this.

I can't able to post full contents of log file.

Contents of Log File is below:

10-11 22:00 INFO   root: === wubi 12.04.3 rev279 ===
10-11 22:00 DEBUG  root: Logfile is c:\docume~1\owner\locals~1\temp\wubi-12.04.3-rev279.log
10-11 22:00 DEBUG  root: sys.argv = ['main.pyo', '--exefile="C:\\Documents and Settings\\owner\\Desktop\\wubi.exe"']
10-11 22:00 DEBUG  CommonBackend: data_dir=C:\DOCUME~1\owner\LOCALS~1\Temp\pyl8E.tmp\data
10-11 22:00 DEBUG  WindowsBackend: 7z=C:\DOCUME~1\owner\LOCALS~1\Temp\pyl8E.tmp\bin\7z.exe
10-11 22:00 DEBUG  WindowsBackend: startup_folder=C:\Documents and Settings\All Users\Start Menu\Programs\Startup
10-11 22:00 DEBUG  CommonBackend: Fetching basic info...
10-11 22:00 DEBUG  CommonBackend: original_exe=C:\Documents and Settings\owner\Desktop\wubi.exe
10-11 22:00 DEBUG  CommonBackend: platform=win32
10-11 22:00 DEBUG  CommonBackend: osname=nt
10-11 22:00 DEBUG  CommonBackend: language=en_US
10-11 22:00 DEBUG  CommonBackend: encoding=cp1252
10-11 22:00 DEBUG  WindowsBackend: arch=amd64
10-11 22:00 DEBUG  CommonBackend: Parsing isolist=C:\DOCUME~1\owner\LOCALS~1\Temp\pyl8E.tmp\data\isolist.ini
10-11 22:00 DEBUG  CommonBackend:   Adding distro Xubuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Edubuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Xubuntu-amd64
10-11 22:00 DEBUG  CommonBackend:   Adding distro Kubuntu-amd64
10-11 22:00 DEBUG  CommonBackend:   Adding distro Mythbuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Edubuntu-amd64
10-11 22:00 DEBUG  CommonBackend:   Adding distro Ubuntu-amd64
10-11 22:00 DEBUG  CommonBackend:   Adding distro Lubuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Ubuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Mythbuntu-amd64
10-11 22:00 DEBUG  CommonBackend:   Adding distro Kubuntu-i386
10-11 22:00 DEBUG  CommonBackend:   Adding distro Lubuntu-amd64
10-11 22:00 DEBUG  WindowsBackend: Fetching host info...
10-11 22:00 DEBUG  WindowsBackend: registry_key=Software\Microsoft\Windows\CurrentVersion\Uninstall\Wubi
10-11 22:00 DEBUG  WindowsBackend: windows version=xp
10-11 22:00 DEBUG  WindowsBackend: windows_version2=Microsoft Windows XP
10-11 22:00 DEBUG  WindowsBackend: windows_sp=Service Pack 3
10-11 22:00 DEBUG  WindowsBackend: windows_build=2600
10-11 22:00 DEBUG  WindowsBackend: gmt=5
10-11 22:00 DEBUG  WindowsBackend: country=US
10-11 22:00 DEBUG  WindowsBackend: timezone=America/New_York
10-11 22:00 DEBUG  WindowsBackend: windows_username=owner
10-11 22:00 DEBUG  WindowsBackend: user_full_name=owner
10-11 22:00 DEBUG  WindowsBackend: user_directory=C:\Documents and Settings\owner
10-11 22:00 DEBUG  WindowsBackend: windows_language_code=1033
10-11 22:00 DEBUG  WindowsBackend: windows_language=English
10-11 22:00 DEBUG  WindowsBackend: processor_name=Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz 
10-11 22:00 DEBUG  WindowsBackend: bootloader=xp
10-11 22:00 DEBUG  WindowsBackend: system_drive=Drive(C: hd 6105.2265625 mb free ntfs)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(C: hd 6105.2265625 mb free ntfs)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(D: hd 38637.5 mb free fat32)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(E: hd 8747.6875 mb free fat32)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(F: hd 24030.09375 mb free fat32)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(G: cd 0.0 mb free )
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(H: cd 0.0 mb free cdfs)
10-11 22:00 DEBUG  WindowsBackend: drive=Drive(I: removable 0.0 mb free )
10-11 22:00 DEBUG  WindowsBackend: uninstaller_path=None
10-11 22:00 DEBUG  WindowsBackend: previous_target_dir=None
10-11 22:00 DEBUG  WindowsBackend: previous_distro_name=None
10-11 22:00 DEBUG  WindowsBackend: keyboard_id=67699721
10-11 22:00 DEBUG  WindowsBackend: keyboard_layout=us

Full Log File can be viewed at http://pastebin.com/18SZHpZ0

share|improve this question
2  
Did you check to see what the error log states? Check the log in: c:\docume~1\owner\locals~1\temp\wubi-12.04.3-rev279.log –  Atari911 Dec 17 '13 at 19:37
    
@Atari911: I saw error log states.But i can't understand how to solve this error. –  Jaimin pandya Dec 17 '13 at 19:40
    
Add the contents of the log file to your post so others can get a look at it... Without the log there is little we can do to understand the problem. –  Atari911 Dec 17 '13 at 21:14
    
@Atari: I have add contents of log file. –  Jaimin pandya Dec 18 '13 at 16:17
    
What version windows? Does the computer have uefi? –  Mateo Dec 18 '13 at 16:22

1 Answer 1

up vote 1 down vote accepted

The following are the relevant lines of your log file that indicate what the problem is:

12-17 09:40 DEBUG btdownloader: downloading http://releases.ubuntu.com/12.04.3/ubuntu-12.04.3-desktop-amd64.iso.torrent > D:\ubuntu\install\ubuntu-12.04.3-desktop-amd64.iso

12-17 10:45 ERROR TaskList: Traceback (most recent call last):

File "\lib\bittorrent\RawServer.py", line 229, in listen_forever

File "\lib\wubi\backends\common\btdownloader.py", line 69, in error_callback

DownloadError: Traceback (most recent call last):

File "\lib\bittorrent\RawServer.py", line 221, in listen_forever

File "\lib\bittorrent\Rerequester.py", line 96, in fail

File "\lib\wubi\backends\common\btdownloader.py", line 69, in error_callback

DownloadError: Problem connecting to tracker - urlopen error (7, 'getaddrinfo failed')>

Wubi is trying to download the ISO image of Ubuntu as a torrent using btdowloader, but btdownloader is unable to connect to the torrent's tracker. There are a number of reasons this may happen:

  • Your client can't get through your firewall.
  • Your ISP's DNS server is down.
  • Your ISP's DNS server can't resolve the tracker's domain to an IP address.
  • The Tracker is down and isn't responding.

If you are using the Windows firewall (or another software based firewall on your computer), then give pyrun.exe (the python runtime that Wubi uses) permission to your windows firewall. If that does not work, then you should download the desktop CD iso yourself from http://www.ubuntu.com/download/ubuntu/download and save it in the same directory as wubi.exe before running (and Wubi will find it and use it).

Information in this answer taken from:

share|improve this answer
    
I need require assistance so I have add log file in my question. –  Jaimin pandya Dec 18 '13 at 16:19
    
This doesn't appear to be the full log file. Please upload the full log file somewhere (e.g. pastebin) and post a link to it. Without being able to see the full log file, it is impossible to know exactly what happened. –  Jet86 Dec 18 '13 at 21:07
    
I have created Full log file in pastebin. Link of Log file is " pastebin.com/18SZHpZ0 ". –  Jaimin pandya Dec 19 '13 at 15:24
    
Your answer is working for me. My computer internet speed was slow. –  Jaimin pandya Dec 21 '13 at 15:26
    
@Jaiminpandya please accept my answer if it worked for you. That would be much appreciated. –  Jet86 Dec 22 '13 at 22:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.