Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 13.10 Saucy Salamander and as most of us know, it is the first Ubuntu version to truly use Smart Scopes. While this is useful and I do like parts of it, I don't want all of the results it brings.

So, I went over to the Filter Results bar and changed it to what I wanted (it was giving me online results over searching my computer and such, such not even bringing up Firefox when I searched for it) and then started the program I wanted.

Later I went back to search and all of those specifications I made were gone. It was bringing up online results first again and all of the defaults I had turned off were back on.

Here's a screenshot of what is happening: firefox search

I don't completely want to remove Scopes, as I have heard this can cause problems, but I really would like the functionality I need.

Also, when I go to, say the Applications Scope, it just shows this:

application scope

I can't browse my applications!

Please help me, as I really don't want to remove Scopes or even down-grade to 13.04!

share|improve this question
    
Problem solved? –  pacificfils Dec 17 '13 at 20:04
    
@FrankSlezak Sorry, I had to go get my braces taken off Hallelujah!Hallelujah! Yes, marking as answer –  RPi Awesomeness Dec 18 '13 at 2:11
    
Glad i could help. WOAH. 777 reputation.... –  pacificfils Dec 18 '13 at 22:19
    
@FrankSlezak I'm too. Lol. We all almost tied for rep :D –  RPi Awesomeness Dec 18 '13 at 22:55
add comment

1 Answer

up vote 1 down vote accepted

Try installing unity-lens-applications

You can do this by sudo apt-get install unity-lens-applications

If that doesn't work, remove it with sudo apt-get purge unity-lens-applications
MAKE SURE IT WON'T REMOVE ANY OTHER PACKAGES! If it does, make a note of them.

Then, sudo apt-get install unity-lens-applications <+ any purged>

Also, try sudo apt-get install unity-scope-home

If that doesn't work, try rm -rf ~/.local/share/zeitgeist and relogging.

share|improve this answer
    
This worked when I ran sudo apt-get purge unity-lens-applications and then sudo apt-get install unity-lens-applications. This didn't seem to work, so I also tried sudo apt-get purge unity-scope-home and then sudo apt-get install unity-scope-home, as per this answer. I then logged out and back in again and it works perfectly! The good old purge-reinstall-logout-login approach works again. –  RPi Awesomeness Dec 18 '13 at 2:16
    
Okay...just rebooted and the issue is back :P –  RPi Awesomeness Dec 19 '13 at 2:50
    
ehrm... it appears to be a config. Try rm -rf ~/.local/share/zeitgeist –  pacificfils Dec 19 '13 at 17:22
    
Do I need to logout and back in again for it to take effect, because just running the command has no effect.. :( –  RPi Awesomeness Dec 19 '13 at 18:16
1  
read the answer... –  pacificfils Dec 19 '13 at 18:29
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.