Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop that dual boots to either Ubuntu 12.04 or Windows 7, but the I can't seem to do anything requiring an Internet connection on the Ubuntu side. I've been through the troubleshooting guide of clearing cache, restarting, etc. to no avail. The wireless icon on the top menu shows that I am connected to my wifi network but firefox doesn't work and I can't use ssh or sftp protocols either. The error message i get with Firefox is "Server not found." Any ideas are appreciated!

ifconfig:

eth0      Link encap:Ethernet  HWaddr e8:03:9a:34:9d:1d  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      Interrupt:41 Base address:0x8000

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:16436  Metric:1
      RX packets:1409 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1409 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:125628 (125.6 KB)  TX bytes:125628 (125.6 KB)

wlan0     Link encap:Ethernet  HWaddr 88:53:2e:94:c2:b7  
      inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::8a53:2eff:fe94:c2b7/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:594 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1109 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:172548 (172.5 KB)  TX bytes:84207 (84.2 KB)

ping google.com:

ping: unknown host google.com

ls -ld /etc/resolv.conf:

lrwxrwxrwx 1 root root 29 Aug 17  2012 /etc/resolv.conf -> ../run/resolvconf/resolv.conf

cat /etc/resolv.conf:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) 
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
search hsd1.fl.comcast.net

ping -c4 192.168.1.1:

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms

ping 192.168.1.1:

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.103 icmp_seq=1 Destination Host Unreachable
From 192.168.1.103 icmp_seq=2 Destination Host Unreachable
From 192.168.1.103 icmp_seq=5 Destination Host Unreachable
From 192.168.1.103 icmp_seq=6 Destination Host Unreachable
From 192.168.1.103 icmp_seq=7 Destination Host Unreachable
From 192.168.1.103 icmp_seq=8 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
11 packets transmitted, 0 received, +6 errors, 100% packet loss, time 10056ms
pipe 3

route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0

dmesg | grep wlan0:

[   28.289967] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   28.290703] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   35.980297] wlan0: authenticate with 00:23:69:c6:c9:c8 (try 1)
[   35.984082] wlan0: authenticated
[   35.992776] wlan0: associate with 00:23:69:c6:c9:c8 (try 1)
[   35.998868] wlan0: RX AssocResp from 00:23:69:c6:c9:c8 (capab=0x411 status=0 aid=4)
[   35.998872] wlan0: associated
[   36.003690] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   46.419609] wlan0: no IPv6 routers present

ifconfig (again):

eth0      Link encap:Ethernet  HWaddr e8:03:9a:34:9d:1d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:41 Base address:0x8000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:147 errors:0 dropped:0 overruns:0 frame:0
          TX packets:147 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:13468 (13.4 KB)  TX bytes:13468 (13.4 KB)

wlan0     Link encap:Ethernet  HWaddr 88:53:2e:94:c2:b7  
          inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::8a53:2eff:fe94:c2b7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:65 errors:0 dropped:0 overruns:0 frame:0
          TX packets:213 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20780 (20.7 KB)  TX bytes:55633 (55.6 KB)
share|improve this question
    
Welcome to Ask Ubuntu. What do you mean by "It doesn't work"? Do you get a error message? Please edit your question and add the information. Can you reach your own router? What happens when try to reach 192.168.1.1? –  MadMike Dec 17 '13 at 16:09
    
MadMike, I added the Firefox error. Could you explain what you mean by "reach my own router"? Thanks! –  bcf Dec 17 '13 at 16:28
    
Try to disable/ignore IPv6. From your post I can see that from the router side everything seems to be ok, because an IP has been assigned to your machine and the config settings seem to be ok too. Edit the wireless connection and set the IPv6 to be ignored and IPv4 to Automatic (DHCP). –  user123492 Dec 17 '13 at 16:30
    
Post the output of the command "ping google.com" –  Jay Dec 17 '13 at 16:58
    
Jay - added result above. User123492 - just did that, but no difference. Thanks for the responses! –  bcf Dec 17 '13 at 17:05
show 12 more comments

1 Answer

Try changing your DNS to Google's: 8.8.8.8, 8.8.4.4
Also change search to: www.google.com

This can be done by right-clicking network, edit connections, select the one relating to the WiFi, Addresses, select DHCP (Addresses Only)

share|improve this answer
    
Okay, just changed IPv4 Settings to Automatic (DHCP) addresses only, then entered "8.8.8.8, 8.8.4.4" into the "DNS servers" box, and "www.google.com" into the "Search domains" box. As per others' instructions I have IPv6 Settings method set to "Ignore". I'm still not able to ping google or access Internet, though. Thanks for the response! –  bcf Dec 17 '13 at 20:03
    
Try the time-tested method known as reboot now. =] –  Mew Dec 17 '13 at 20:04
    
believe me, I've tried that many times! Whatever this problem is, it sure is frustrating. Nothing seems to be working and yet the menu bar shows I am connected and it still works fine on the Windows side. –  bcf Dec 17 '13 at 20:30
    
post results of ifconfig again please. –  Mew Dec 17 '13 at 20:34
    
just added to original post –  bcf Dec 17 '13 at 20:59
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.