Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've been working on an issue of calculation for months, but I can't get my wireless card to work. It always shows to me : Device not ready.

My laptop is Acer 4750g with Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) and the Ethernet controller is Broadcom Corporation Netlink BCM57785 Gigabit Ethernet PCIe.

I've tried

sudo service network-manager restart

but nothing changed.

After that, I've updated my wireless card diver from http://www.broadcom.com/support/license.php?file=570x/linux-3.118k.zip

And I got :

Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: off
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x000000ff (255)
                   drv probe link timer ifdown ifup rx_err tx_err
Cannot get link status: Operation not permitted

Does anyone knows how to fix the problem?

share|improve this question

marked as duplicate by Luis Alvarado Jul 25 '14 at 2:04

This question was marked as an exact duplicate of an existing question.

Try this (Suspend problems in 13.10) or this (How to restart the networking service?), there should be something in all the solutions what can help you.

share|improve this answer
    
No, I've tried bash and restart network-manager already. It does not work for me. Thank you for the reply. – Laurent Dec 17 '13 at 11:48

I have the same problem and it's solved by removing and immediately reinserting the modules for the wireless.

sudo rmmod rt2800usb && sleep 3s && sudo modprobe rt2800usb

or

sudo rmmod ath9k && sleep 3 && sudo modprobe ath9k

Notice that this are the commands I use in my laptop and in my desktop. You'll need to find out which modules your wireless uses. I think by your post you're using a Qualcom Atheros like mine, so try the second command first.

Good luck!

share|improve this answer
    
Thank you for your reply. I choosed the second command, and nothing seems changed. I've already add in /etc/modprobe.d/ath9.conf to close the wake on lan by echo > – Laurent Dec 18 '13 at 12:56

Finally, I've tried with Chili555, please check another question posted.

Ubuntu 12.04 LTS Network Icon Mistaken

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.