Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a rather strange problem to report. I have installed the fglrx module for my AMD HD7750 gfx card, multihead (not Xinerama). When executing a screenlock in XFCE (by default, xscreensaver), and then turning off the monitor, xscreensaver crashes with:

xscreensaver crashed with SIGABRT in __GL_raise()

Which of course unlocks access to the desktop.

This also occured in Debian 7.x on the same machine/same gfx card. If only one monitor is turned off, and the xscreensaver itself doesn't crash, the desktop of the other monitor which is still powered-on will be exposed, although the screen will still be locked for input.

I have also tried this with gnome-screensaver. I haven't yet seen a crash, but I have seen the exposure of the other still-powered-on screen a few times (although not every time).

One solution i've found is to disable OpenGL screensavers either via the 'Settings' button when manually starting xscreensaver (or via the ~/.xscreensaver 'mode blank' config line).

System: Ubuntu 13.10 x64 3.11.0-14-generic)
WM: XFCE4
GFX: fglrx (apt-provided: 2:13.101-0ubuntu3)
    direct rendering: Yes
    server glx vendor string: ATI
    server glx version string: 1.4
xscreensaver: 5.15-3ubuntu1
gnomescreensaver: 3.6.1-0ubuntu7

I just wanted to bring this to people's attention, as this could be a security issue.

cheers

sc.

share|improve this question
    
Please report this as a bug on the bug tracker! See the link in the close reason for how to do that. –  Oli Dec 17 '13 at 11:47
add comment

closed as off-topic by Oli Dec 17 '13 at 11:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Oli
If this question can be reworded to fit the rules in the help center, please edit the question.