Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 13.10 from 13.04 my wireless card connects to the router, the router is connected to internet (I am sure about that) but still no internet access for my laptop!

I am using Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter.

iwconfig gives me:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:"asteras"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 80:1F:02:8D:4E:8C   
          Bit Rate=72 Mb/s   Tx-Power=200 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Not blocked by anything, I use wl proprietary driver and I also used brmcsmac but it didn't work at all, I couldn't even connect to a wireless network.

share|improve this question
add comment

5 Answers 5

If I were you and judging by lots of other people on this site I would do a clean install of the Broadcom wifi drivers. It does not take long and in my experience usually works very well

Fire up a terminal which you seem to know what to do.

Then clean old packages

sudo apt-get remove bcmwl-kernel-source

Gone!

Then reinstall the driver

sudo apt-get install bcmwl-kernel-source

This should reinstall the driver but experience shows us that Broadcom 4313 can be a little more tricky and you may need to ensure it is on the blacklist file

sudo gedit  /etc/modprobe.d/blacklist.conf

Then insert the following in the list

blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ndiswrapper

Again this should work but if does not (BCM 4313 is extra special remember!) the opposite can also apply and you may need to add a hash # in front of where you see :

blacklist bcm43xx

so it says :

#blacklist bcm43xx

I always find then that a little nudge helps with the final command

sudo modprobe wl

Almost immediately my wifi wakes up (maybe wl stands for wakeup lazy! - I know it does not really )

Hope that helps. Does not take long and should work.

Let us know how you get on

If you want more information there are lots of people here who have scars from Broadcom wifi battles with excellent guide written here

How to Install Broadcom Wireless Drivers (BCM43xx)

share|improve this answer
add comment

You seems to be connected well to the wireless, but what about your ip configuration ?

Please check :

  • With ifconfig if you have an ip. If your device do not appears, try "sudo ifconfig up eth0"
share|improve this answer
add comment

You are connected to access point asteras, but you did not get any IP address. Suspicious is, that you say it is a wireless but it is marked eth1. Native wireless is usually marked as wlan0.

You have to get following in your ifconfig result:

eth1 ...
     inet adr:x.x.x.x  gate:x.x.x.x  Mask:255.255.255.0
     inet6-adr: fe80::1e75:8ff:fe5e:39d5/64 ...

try to put eth1 (sudo ifconfig down eth1) down and up (sudo ifconfig up eth1) again.

This could be caused by the router/ap itself, usually because your mac address is not allowed. Then you can connect to the radio, but you will not receive any IP address, because your communication is not allowed. Try to check router settings.

share|improve this answer
add comment

I suggest you try an earlier version of bcmwl-kernel-source. I recommend that you get a temporary wired ethernet connection and open a terminal:

sudo apt-get remove --purge bcmwl-kernel-source
wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb

Or, if yours is a 32-bit system:

wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_i386.deb

Confirm 32- or 64-bit:

arch

Then do:

sudo dpkg -i bcmwl*.deb

Reboot and give us your report.

share|improve this answer
add comment

Thank you very much people for your help. I post the solution to my problem here.

I saw that this problem doesn't exist in other wireless connections except my home one. The problem was in the band mode. There must be something going wrong with the N mode, so I just selected B and G modes and the problem was resolved and I got online again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.