Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

WebDAV (via SSL) is configured on a VirtualHost on my root-Server. SSL is working fine with all clients and other applications running below this virtual host are working. Unfortunately WebDAV does not.

Nautilus as Client works well, cadaver as client works only on some (php) files, not on all. An old Internet Explorer 6 is working as well, but recent clients on Mac OS X and Windows do not work.

Both dav-modules are enabled, files and directories are owned by www-data:www-data and the following excerpt is part of my config (anonymized).

NameVirtualHost 1.2.3.4:443
<VirtualHost 1.2.3.4:443>
    ServerName server.example.com

[...]

    # WebDAV
    DavLockDB /srv/dav/lockdb

[...]

    Alias /serendipity "/srv/www/webdav"
    <Directory "/srv/www/webdav">
        DAV on
        ForceType text/plain
        Options +Indexes
        AllowOverride None
        AuthType Basic
        AuthName "Serendipity Testblog"
        AuthUserFile /srv/pwd/serendipity
        Require valid-user
    </Directory>

[...]

</VirtualHost>

Any ideas?

share|improve this question
add comment

2 Answers

Add a line beneath the DAVLockDB directive, which says:

ForceType text/plain

This will tell Apache not to evaluate scripts but answer their file content instead.

Good luck...

share|improve this answer
add comment

To add to this: DAV itself is working and shows directories and files, but file retrieval only results in the HTTP-parsed representation of a file. That means, PHP gets parsed and the downloaded file shows the file as if it were viewed inside a Browser.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.