Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to format my hard drive. i booted Ubuntu 13.10 but the hard drive is not available for mounting. The hard drive is also not detected in either fdisk or gparted utilities. There is no sda* file in /dev/. It is as if there is no hard disk.

I tried installing windows8 but in the partition manager no hard disk is displayed. But when i start the windows repair console I can see my hard disk named as X: where all my files are intact but when i try to format the hard disk from here, i get 'volume label error '. It is as if the HDD has become read only.

After that, i booted live with freeBSD and tried to format from the root shell but fdisk cant detect the drive.

i also tried configuring the jumper of my motherboard and hard disk but to no avail.

There is a continuous intermittent beep sound as i start my computer.

my configuration is : motherboard: D945gcr ram:1 gb processor: Pentium 4 hard disk: Seagate 160 gb ultra ATA (u series 8)

please help how to repair my computer.

share|improve this question
    
Welcome to Ask Ubuntu. The beep code is trying to tell you what is wrong with your hardware. There is a beep-code list. I hope it applies to your board. –  MadMike Dec 17 '13 at 6:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.