Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought an MSI GS 70 Stealth Notebook with Windows 8 preinstalled. I updated it to Windows 8.1 and reinstalled all the latest drivers and BIOS/firmware. I tried to install Ubuntu GNOME 13.10 after changing the boot mode from UEFI to Legacy (which also turns Secure Boot off).

First I tried to boot from the Live CD without installing. It gave me the Gnome logo with dots underneath but hung here and never changed. After looking around I found this site where apparently someone had got it working:

http://gs70-linux.blogspot.com/

I tried booting from the Live CD by replacing the quiet splash options with nomodeset. This worked and Ubuntu GNOME booted just fine and WiFi and everything else worked fine.

At this point I continued to install Ubuntu normally. It seemed to install correctly, when I rebooted I switched back to UEFI mode and tried to boot normally. I was greeted with grub. There was an entry for Ubuntu, but no Windows. I tried booting into Ubuntu and got only a blank screen. I tried restarting and editing the boot options at grub replacing quiet splash with nomodeset again, but this didn't work.

At this point I used to Live CD to boot back into Ubuntu and installed and ran the boot-repair utility. During some of the commands it had me copy into the terminal I got some warnings back:

source_dir doesn't exist. Please specify --target or --directory.

grub-efi-amd64-signed depends on grub-efi-amd64; however, 
Package grub-efi-amd64 is not configured yet.

Even though I got these warnings it appeared the utility finished running successfully. It gave me the following URL: http://paste.ubuntu.com/6584972

It told me to make sure that it boots from sda2/EFI/ubuntu/shimx64.efi.

After this I rebooted and switched back to UEFI. After rebooting normally I got grub again, this time with entries for Windows 8 and Windows recovery. I was able to boot into Windows 8 just fine. Ubuntu still hangs on a blank screen and doesn't load. If I hit the advanced options and try to select any of the ubuntu options it stops at Loading initial ramdisk. Trying to hit e and changing quiet splash to nomodeset doesn't change anything.

Anyone have any advice about what I can try next.

share|improve this question
add comment

1 Answer 1

Here are a few more options to try to fix the video (?) problem: Options for Video problems:

nomodeset
acpi=0
acpi_osi=linux
acpi_backlight=vendor
noalpic
i915.i915_enable_rc6=1
video=1280x1024-24@60
video=VGA-1:1280x1024-24@60

To allow Nvidia hybrid machines to boot.

nouveau.blacklist=1

To slow SSDs to allow them to boot: libata.force=noncq

share|improve this answer
add comment

protected by Community Mar 9 at 23:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.