Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an Asus EEE PC 1005HAB, and after upgrading to 11.04 I can no longer use Fn+F7 to turn on/off the screen backlight. The other Fn+FX keys I've tried so far all work. Is there some standard fix, or should I report this? A quick Google search didn't turn up anything.

share|improve this question

closed as off topic by Marco Ceppi May 21 '12 at 20:57

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Yeah this should probably be a bug report. Instructions here. –  Jorge Castro May 2 '11 at 15:14

4 Answers 4

up vote 2 down vote accepted

I used a Eee PC 1005HA to confirm this. Running dmesg I get:

keyboard: can't emulate rawmode for keycode 244

The keycode refers to XF86KbdLightOnOff, so I think this is a bug.

Workaround:

  • Use xrandr -q to get the monitor's name, should be something like LVDS1.
  • Use compizconfig-settings-manager Install compizconfig-settings-manager commands plugin to set hotkeys to:
    • xrandr --output LVDS1 --off change LVDS1 with your monitors name.
    • xrandr --auto dont use output with this command, it seems to cause window glitches.
share|improve this answer

u can have an alternative to turnoff the backlight of lcd whenever u want just type "xset dpms force off" and press enter in terminal or make a desktop launcher of it and attach it in the unity panel , if ur using gnome shell then there's a gnome shell extension to attach desktop launcher to the top panel. hope this will solve ur problem with a single click u can turnoff ur lcd . if possible make a shortcut to "xset dpms force off" or the desktop launcher to this command. hope this may help

share|improve this answer

An upgrade from 10.10 to 11.04 removed several packages from me. One of them was smartdimmer. It's package description is:

Nvidia Geforce 6200Go, Geforce 8, Geforce 9, and other cards contain hardware LCD brightness control. Smartdimmer allows this to be controlled through software.

Try installing it, I do not guarantee anything though.

The logs of the upgrade process can be found in /var/log/dist-upgrade, and the log for installed / removed packages in /var/log/dist-upgrade/history.log.

share|improve this answer
    
Does smartdimmer work for cards other than Nvidia? I can't control screen brightness on my laptop with Intel card even though the brightness meter/slider can be moved up and down. –  Oxwivi May 2 '11 at 11:43
    
I don't think so. Could you try manually setting the brightness level using the /sys interface? Run: cd /sys/devices/virtual/backlight/acpi_video0, followed by cat brightness max_brightness. The first number is your current brightness, the second your maximum brightness. The minimum value is 0 (zero). To change it to 3, run: echo 3 | sudo tee brightness. Please report any errors back. –  Lekensteyn May 2 '11 at 11:48
    
Lekensteyn, I think because of my attempts to change brightness (i.e. lower it), the brightness output was 0. I ran the command to change it to three, and after inputting password, output of only 3 was shown. No noticeable change in brightness. –  Oxwivi May 2 '11 at 12:22
    
@Oxwivi: this bug on Launchpad may be of interest for you. –  Lekensteyn May 2 '11 at 12:28
    
That bug I believe is due to the kernel. –  Oxwivi May 2 '11 at 13:11

i have made a unity launcher to turnoff the lcd u can also try this

sudo apt-get install --no-install-recommends gnome-panel

gnome-desktop-item-edit ~/Desktop/ --create-new

it will open a small windows

in name type : turnofflcd

in command type : xset dpms force off

i have read abt making launcher from this website: http://www.ubuntugeek.com/how-to-create-desktop-launchers-in-ubuntu-11-10oneiric.html

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.