Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot access internet.

I can access the configuration page of my router, but no web page.

When booted on Windows, the same computer has full internet access.

I don't know what happened. Someone may have changed something regarding the router, but I really don't know.

It seems that my linux networking configuration is somehow screwed up. See below for terminal outputs.

Please help me! Thanks!

EDIT:

Contrary to my expectations, the issue seems to be more network-related than config-related.

I have internet access while using another network. I could not test this when I posted.

Additional info

The network causing the trouble has a MAC address filter. The two addresses of my computer (wired & wireless) are in the list. It is set to accept the devices in the list. The security is WPA2. As I can access the config page of the router, the issue does not seem to relate to security.


Terminal outputs

(If you know how I can change the language of these outputs, tell me!)

inxi -N

Network:   Card-1: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe driver: tg3 
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl 

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:26:b9:02:95:b3  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:850 erreurs:0 :0 overruns:0 frame:0
          TX packets:566 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:75127 (75.1 KB) Octets transmis:69582 (69.5 KB)
          Interruption:17 

eth1      Link encap:Ethernet  HWaddr 00:22:5f:eb:85:4d  
          inet adr:10.168.5.124  Bcast:10.168.5.255  Masque:255.255.255.0
          adr inet6: fe80::222:5fff:feeb:854d/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:548 erreurs:0 :0 overruns:0 frame:23992
          TX packets:1720 errors:16 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:61212 (61.2 KB) Octets transmis:184595 (184.5 KB)
          Interruption:17 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:332 erreurs:0 :0 overruns:0 frame:0
          TX packets:332 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:14960 (14.9 KB) Octets transmis:14960 (14.9 KB)

iwconfig

lo        no wireless extensions.

eth1      IEEE 802.11abg  ESSID:"Phoenix"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 98:2C:BE:F9:C6:59   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

eth0      no wireless extensions.

sudo lshw -C network

  *-network               
       description: Interface réseau sans fil
       produit: BCM4312 802.11b/g LP-PHY
       fabriquant: Broadcom Corporation
       identifiant matériel: 0
       information bus: pci@0000:04:00.0
       nom logique: eth1
       version: 01
       numéro de série: 00:22:5f:eb:85:4d
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) ip=192.168.0.114 latency=0 multicast=yes wireless=IEEE 802.11abg
       ressources: irq:17 mémoire:f8000000-f8003fff
  *-network
       description: Ethernet interface
       produit: NetLink BCM5784M Gigabit Ethernet PCIe
       fabriquant: Broadcom Corporation
       identifiant matériel: 0
       information bus: pci@0000:08:00.0
       nom logique: eth0
       version: 10
       numéro de série: 00:26:b9:02:95:b3
       taille: 100Mbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.121 duplex=full firmware=sb v2.17 latency=0 link=no multicast=yes port=twisted pair speed=100Mbit/s
       ressources: irq:47 mémoire:fc100000-fc10ffff
share|improve this question

3 Answers 3

up vote 1 down vote accepted

During research I noticed that I could ping IP addresses but no domain names.

I resetted resolv.conf by moving it using this command:

sudo mv /etc/resolv.conf /etc/resolv.conf.bak

Everything got back to normal instantly.

I googled: "wifi connected unknown host".

share|improve this answer

Your iwconfig output leads me to suspect that you haven't authenticated to the wireless network. Does it use WEP, WPA2 or ??. Check /var/log/syslog* for mention of eth1. If needed, check /var/log/* for mention of eth1.

By "check", I mean sudo grep eth1 /var/log/syslog*|tee eth1.tmp | less or similar.

Have you explained your encryption/authentication scheme to NetworkManager?

Here's part of my iwconfig output, when I'm connected to my wireless (especially note the "Bit Rate" line):

wlan0     IEEE 802.11bgn  ESSID:"Fairfield"  
      Mode:Managed  Frequency:2.417 GHz  Access Point: 14:D6:4D:2D:5F:AE   
      Bit Rate=36 Mb/s   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=39/70  Signal level=-71 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:158  Invalid misc:504   Missed beacon:0
share|improve this answer
    
Thanks for your answer. I've edited my post to answer some of your questions. "Have you explained your encryption/authentication scheme to NetworkManager": I don't understand. Do you mean selecting WPA2 in the network manager? –  Carl Lemaire Dec 18 '13 at 19:57
    
Yes, I mean selecting WPA2 (matching the wireless router), and entering the correct userid and/or password. Until your iwconfig doesn't show at least the Bit Rate= line, IMHO, you're not authenticated. Some hint must have been logged. Have you checked /var/log/*? Also, if you use sudo ifconfig, it will show MAC addresses for each interface. –  waltinator Dec 19 '13 at 20:57

When booting up the computer select "Advanced Options for Ubuntu" and choose a different Linux kernel version. It should fix your Wi-Fi problems, while booting into the older linux kernel you should try and perform any system updates and try booting into Ubuntu normally again.

Don't worry about losing any files and settings as they'll still be there.

Not sure if this is 100% certain but it worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.