Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a newbie who has just installed 12.04 in my Intel I3-550 home built computer. Is there supposed to be a GUI for WiFi? There is no mention of it in the Applications list.

My previous computer was a windows OS and it had a little icon at the bottom right which one clicked on and it showed networks in the area. Is this the way Ubuntu works?

Right now I am connected over ethernet, but am baffled at how to connect via WiFi.

i

fconfig:
eth0      Link encap:Ethernet  HWaddr 48:5b:39:94:28:00  
          inet addr:192.168.0.143  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::4a5b:39ff:fe94:2800/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1683232 errors:0 dropped:0 overruns:0 frame:0
          TX packets:550623 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2246831369 (2.2 GB)  TX bytes:86014926 (86.0 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8160 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8160 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1194958 (1.1 MB)  TX bytes:1194958 (1.1 MB)

lspci:
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA IDE Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.5 IDE interface: Intel Corporation 5 Series/3400 Series Chipset 2 port SATA IDE Controller (rev 06)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
02:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
share|improve this question
    
I can't see a wifi device in the list. Is this an internal card or an external USB wifi adapter? –  falconer Dec 16 '13 at 9:41
    
Is your wifi adapter a usb device? If so, try opening a terminal and type lsusb | grep Network. Edit your question with this info. –  To Do Dec 16 '13 at 10:16
    
Have you checked additional drivers for a 3rd party proprietary driver for your wifi? It's in Settings. –  Silviu Dec 16 '13 at 10:30
    
ToDo. I borrowed a USB adapter, copied and pasted, "lsusb | grep Network", but got no response whatsoever (whether with or without sudo). Is there comething else I can try? Odysseus –  Odysseus Dec 16 '13 at 18:19

2 Answers 2

If wifi is not working then , 1st time initially you should connect your pc/laptop with cable/LAN network and try these step:-

Open Additional Drivers option in ubuntu ( press windows key and find "Additional Drivers" or you can also find this option in "system settings"),

it will automatically find correct drivers for your pc/laptop and choose option to select and install it.

Generally it will find wifi, graphic Proprietary drivers.

share|improve this answer
    
I am connected on this computer via ethernet. I opened Additional Drivers and this was the result: "No proprietary drivers are in use on this system." I suspect that Falconer is correct, and that the mobo does not have wifi built in. Is there any way to verify this from within Ubuntu, or do I need to open the case, find the mobo mfgr and model and look for it that way? Thanks. –  Odysseus Dec 16 '13 at 14:25
    
ToDo. I could not figure out how to answer you at your comment, so am adding here. I borrowed a USB adapter, copied and pasted, "lsusb | grep Network", but got no response whatsoever (whether with or without sudo). Is there comething else I can try? Odysseus –  Odysseus Dec 16 '13 at 18:18
    
OK, I am using my earlier response to Gaurav to report progress. As you can see above in comment to ToDo, I plugged in an adapter (It is an AirLink 101). Trying different things, I clicked on "Connect to Hidden Wireless Network", filled in the name of a known AP here in my home and lo, it connected. I disconnected the ethernet cable and am now communicating over WiFi. I did not post this as an "Answer" because I am unsure of how what has happened has occurred, and would be interested in your feedback? Thanks. P.S. For info, the opposing up down arrows in the panel are now the wireless symbol. –  Odysseus Dec 16 '13 at 18:38
    
ubuntu drivers are not directly work with some hardware/devices so additional drivers work well and often "connect to hidden wireless Network" option is better for connection because if hardware/device wifi is not working then it try to connect forcely. My Toshiba laptop is supported Window 7,8 but if i am using ubuntu then after starting the ubuntu every time i use "connect to hidden wireless Network" option either need to sleep the laptop for 1/2 min. to working the built-in wifi. –  Gaurav Sharma Dec 17 '13 at 7:21
    
If LAN internet connection not supporting then you try to sleep/lock Screen the pc for some minutes and then restart of retry the LAN internet connection, now see NET is working and try to update graphic or ethernet/wifi drivers. IF these option not working then use current wifi connection that you recently found. –  Gaurav Sharma Dec 17 '13 at 7:27
  • To enable wifi in Ubuntu,click on the network icon on the top panel.

  • Then enable the wifi.After that,it searches for the nearby wifi networks and automatically connected if it was open and prompted for password if it was secured.

enter image description here

share|improve this answer
    
Avinash, Thanks, but there is not icon in the top panel. I am using Gnome rather than Unity. Would that matter? Please see my other comments. –  Odysseus Dec 16 '13 at 14:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.