Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm testing Ubuntu12.04 MAAS with juju ,i installed the maas server and add 2 nodes now the nodes allocated to admin user when i start them login is required i tried the admin username and password but always got error "login incorrect" any one can help me please

share|improve this question
juju ssh <machine-id> easiest , and:

ssh ubuntu@<host> roughly equivalent. You'll always need to log in as the ubuntu user, and you'll need to authenticate with one of the private keys (id_dsa, id_rsa, or identity) in your ~/.ssh directory.

(When you bootstrapped, juju will have looked in ~/.ssh and automatically chosen one of, and to authorize for all machines; if necessary, you can override this behaviour by setting authorized-keys-path in your environment configuration, but you may need to do more work to configure ssh to use the appropriate private keys.)

share|improve this answer
thank you very much i tried juju ssh <machine-id> but got ERROR no reachable servers also tried ssh ubuntu@<host> and got ssh: Could not resolve hostname node0: Name or service not known i tried enter the username 'ubuntu' and admin's username and pw but also got login incorrect i didn't understand what to do with ssh key i already configured – eng. alhasani Dec 19 '13 at 7:09
It sounds as though your machine can't see the maas network. Try adding a nameserver as described here. – fwereade Dec 19 '13 at 16:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.