Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed PyCharm on my brand new Ubuntu 13.10 laptop.

To launch PyCharm, I find I must navigate to the directory that pycharm lives in, and execute it from there as such:

cd home/matt/software/pycharm/bin sh

I hope this isn't asking too much, but I would like to be able to click on an icon in the Launcher to launch this application.

I tried right-clicking on the PyCharm icon in the Launcher when the app is running and selecting "Lock To Launcher" but this doesn't work (after pinning, when I try to run the software this way, the icon throbs in a very awkward manner a few times and does nothing).

A small app called Alacart was rumoured to be useful, but I have no idea how it works, and it appears useless. I'm not sure why the authors teased us with a "Help" button if there are no help files written for us to view.

Further attempt has included reading page after page of technical documentation on how to write scripts that will somehow help me customize my experience.

How can I set up PyCharm to launch from the Launcher???

share|improve this question
up vote 61 down vote accepted

PyCharm can create it's own launcher icon (but it's not created by default).

All you have to do is:

  1. Start PyCharm.
  2. From the Tools menu, select "Create Desktop Entry..."
  3. Tick the corresponding box if you want the launcher for all users.
  4. If you selected "Create entry for all users", you will be asked for your password.
  5. A green message bubble should appear informing you that it was successful.
  6. You should then be able to find PyCharm in the Unity Dash or pin it to the launcher.

Note: You may need a system restart before it appears.

share|improve this answer
Thanks for you answer! I did what you recommended, but alas, when I click on the icon I now have pinned to the Launcher, it just throbs in a very awkward manner a few times and does nothing. Very confusing.. – Matt O'Brien Dec 16 '13 at 8:12
@MattO'Brien Can you find a PyCharm file in ~/.local/share/applications (for your user) or /usr/share/applications (for all users). Right click this > Properties, and check the 'Command' field. – minerz029 Dec 16 '13 at 8:15
The 'Command' field says, "/home/matt/software/pycharm/bin/" %f Is there something wrong with this? – Matt O'Brien Dec 16 '13 at 8:27
@MattO'Brien I think you just need to run this chmod a+x /home/matt/software/pycharm/bin/ – minerz029 Dec 16 '13 at 8:34
Thanks, works also with Mint – Pierre de LESPINAY Apr 25 '15 at 7:46

I had the same problem after "Create Desktop Entry...". This is what solved my problem: Go to the bin folder of the PyCharm and add following line to the beginning of script:

export JDK_HOME='your java home folder'

and save the file. now run the launcher entry from unity. enjoy ;)

share|improve this answer
This fixed my problem, finally! Been looking for a solution for this one for a while. Thanks! – diplosaurus Feb 18 at 23:44
@diplosaurus you are very welcome! – Basir Shariat Feb 22 at 8:46

There is a program called "main menu" available from the software centre. It allows you to make launchers for any command.

Also you need to run the cd and the launch as one command like this:

sh -c "cd /folder/to/go/to  && launch-command -options"

Click new item Click new item

Enter a name for the launcher and the command, and maybe a picture Enter a name for the launcher and the command, and maybe a picture

share|improve this answer
If you read the original version if this it may not work because of the lack of the single command using sh. Check edited version above. – Julian Stirling Dec 16 '13 at 7:20
please forgive me. Once I create this New Item, what is the next step? My Launcher is just sitting there in the "Main Menu" app. How do I make this useful? – Matt O'Brien Dec 16 '13 at 7:58
Ahh, here we get confused because I use Gnome not Unity. It should now appear in the Unity Dash. I assumed you could drag it from there to the unity launcher bar thingy like I can in Gnome. – Julian Stirling Dec 16 '13 at 8:05
Look in the folder: ~/.local/share/applications can you see the launcher? Open dconf editor (install if you don't have it) and go to: "desktop-> unity-> launcher -> favorites" Try adding the name of the launcher into that list. – Julian Stirling Dec 16 '13 at 8:13
Under "desktop-> unity" we only have "lenses" and "runner." – Matt O'Brien Dec 16 '13 at 8:23

protected by Community Mar 9 at 4:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.