Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Tried installing 13.04 to an old Win 2K machine as dual boot. Downloaded .iso, burned to CD, then put into machine. I said install next to Win2K.

Afterwards, boot fails. Couldn't figure it out, nor how to uninstall. Posts said install another version wipes out prior Linux. So I tried 12.03.4 or whatever. Got a different boot error, simply file not found. So I tried again with 13.10. Same as original error.

Error is:

Error: file  /boot/grub/i386-pc/normal.mod not found
grub rescue>

I did some looking at posts, which are hard to decipher for a total newbie . . . Did the ls command, which yields (hd0)(hd0,msdos6)(hd0,msdos5)(hd0,msdos1)(fd0) I think it is just a single hard drive, but not sure.

I have no idea which might be the boot partition? Maybe the non-msdos ones? I tried an eHow.com set of steps to set prefix and then root and then say insmod normal, but it didn't seem to work and the computer still doesn't boot.

If I interrupt the boot sequence I can start from the CD and run Ubuntu that way as a test.

But my computer is stuck and won't boot from the hard drive. What can I do? In detail, please - I'm OK in Windows terminology but linux is "Greek" to me.

Later info 12/18/13: After looking at other posts with this "generic" problem, I did "ls" for each of the ?drives,: ls (hd0)/ and so on. The boot one is supposed to yield "lost+found and so on." Most yielded "unknown file system." (hd0,msdos6)/ yielded a blank line. (fd0)/ yielded "Error: failure reading sector 0x2 from fd0"

So I still have no idea which is the "right" partition.

12/20/13 update. Installed from"live" DVD session, telling it to uninstall and re-install Ubuntu. Seemed OK. Upon reboot, same error as above. Doing the "ls" command yields the same results also. The msdos6 version yielded a blank line.

Maybe I'll try to uninstall per a "Dillmo" post of Jun 30.

12/22/13 Final update. I had no luck. Gave up. The uninstall led me down a dead end. So I went old-school. Used a floppy to run Fdisk and delete all partitions. Then used a 2009 article from Computer World to prepare partitions for Ubuntu. Tried first install from "live" session. But it stalled early on. Sigh. Tried agai, but this time install, not trail (live) session. It worked.

Running 13.10 and it seems fine Now I need to learn a little about linux . . .

share|improve this question
    
Not sure about your specific problem, but I think I have had more luck when running the install from the running Ubuntu (as you called it "run Ubuntu as a test"). Also, try this question as a starting point. –  nobar Dec 15 '13 at 22:55
    
Was the live version of ubuntu working? –  Pascal Fares Dec 15 '13 at 23:35
    
The live (CD-DVD) version runs, after taking a while to load. Maybe I'll try to install again from that "desktop," if my Windows brain can adapt to Linux. –  RichU Dec 19 '13 at 0:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.