Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am running usb-creator-gtk.

After copying files it says: "system policy prevents installing the bootloader".

Why does it say this? I am not trying to modify my system. I am creating a bootable USB drive. I don't understand why modifying a thumb drive would require administrator privileges.

share|improve this question

marked as duplicate by psusi, Thomas W., minerz029, karel, chronitis Dec 16 '13 at 10:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I found that the Disks utility (gnome-disks) can be used as a replacement for usb-creator-gtk (there is an option called "Restore Disk Image"). This also requires administrator privileges, but I got the sense that it was less buggy than usb-creator-gtk. Just be sure that you select the correct USB device. –  nobar Dec 16 '13 at 1:02
    
Or just use the dd utility to copy the .iso file to the USB device. –  nobar Dec 16 '13 at 1:04
    

1 Answer 1

Because the system policy for usb-creator-gtk is set up like that. See the /usr/share/polkit-1/actions/com.ubuntu.usbcreator.policy file and the /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla file. Why? I don't know, maybe the usb-creator code is not safe enough, and the program can be used even to modify internal drives. Maybe it is safe, but the creators don't want to risk it, so they chose not to allow modifications without privileges.

If you don't like that, you can override it (of course that process will require root privileges).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.