Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the last question, (How to insert Video element in my Ubuntu application?) I thought that I could create the Video element with the QtMultimediaKit1 . But I tried to import QtMultimediaKit 1.0 and it doesn't worked! I eventually found out that I could import it with import QtMultimedia 5.0.

Although it was working, I managed to find it in the Software Center. I noticed that the modules started with "libqt...". And there it is! Or there THEY are! Because I found out that the installed module (QtMultimediaKit 1.0) and the imported one (QtMultimedia 5.0) are two different things!

QtMultimediaKit 1.0

not the same as

QtMultimedia 5.0

The compiling error is the same as in the last question when I use QtMultimediaKit 1.0.

What are the differences between both of them?

Why wont the QtMultimediaKit 1.0 work?

I saw some documentation about it :

I tried with QtMultimediaKit 1.1 instead of 1.0 but it's the same problem:

(file path)/ConfigureButtonTab.qml:4 module "QtMultimediaKit" is not installed

/usr/lib/x86_64-linux-gnu/qt5/bin/qmlscene exited with code 255

I'm still under 13.10 and with Qt Creator 2.8.1 based on Qt 5.0.2 (GCC 4.7.3, 64 bit) built on Sep 16 2013 at 12:02:18.

P.S.: A little additionnal question: how can I know what to install to have the right module? For instance, the 3D module: I have something installed but I do not know what to import and if it's realy the right module (the installed-one is: Qt 3D module: libqt53d5)

Thank you! : )

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is because Ubuntu Touch uses Qt 5 and qtmultimediakit is an older Qt Mobility module. See this quote from Qt's website:

The Qt Multimedia module in Qt 5 combines (and replaces) two older modules, namely the Qt Multimedia module from Qt 4.x, and Qt Multimedia Kit module from Qt Mobility. Existing code that uses Qt Multimedia from Qt 4 can be ported with minimal effort, but porting code that uses Qt Multimedia Kit may be a more involved process. The changed features section highlights changes relevant to porting.

In other words, the Qt Multimedia module in Qt 5 is the successor to QtMultimediaKit. Since Ubuntu Touch only uses Qt 5 I don't think QtMultimediaKit would work.

The reason your import didn't work was because the QtMultiMediaKit files are stored in /usr/lib/<architecture>/ while the SDK only looks in the qt5 folder of /usr/lib/<architecture>/.

Long story short, using the Qt 5 Multimedia Module is the right way of doing it!

share|improve this answer
    
Thank you! Just an additionnal question about the end. How to import the 3D module (Is it a Qt4/5 problem too?)? And how to improt it (Should I change a path, so that the SDK looks in /usr/lib/<architecture>/)? –  tuxtoriel Jan 22 at 20:40
    
@tuxtoriel I don't know. That really should be a separate question. –  Seth Jan 22 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.