Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my instance of Ubuntu Server from 12.10 to 13.10 and I can't access munin anymore.

I had the issue with Apache2.4 where some options have changed and have applied the fixes suggested here: Ubuntu 13.10 Server - 403 error after upgrading to apache2.4 And here: http://stackoverflow.com/questions/9127802/munin-server-with-apache-you-dont-have-permission-to-access-munin-on-this-se

Doing that got most of my other other sites back up, but munin is still giving me a 403 error.

I then tried a full purge of munin and it's config files and a re-install, re-applied the apache2.4 fix, and it is still giving me the 403 error.

In the error log for munin I get this:

[Sat Dec 14 21:42:13.458130 2013] [authz_core:error] [pid 29896] [client 192.168.1.1:57620] AH01630: client denied by server configuration: /usr/lib/munin/cgi/munin-cgi-html
[Sat Dec 14 21:42:13.865968 2013] [authz_core:error] [pid 29896] [client 192.168.1.1:57620] AH01630: client denied by server configuration: /etc/munin/static/favicon.ico

I tried accessing munin by forwarding a port to the server and trying to access it through a local connection, but no success there.

Here is what my /etc/munin/apache.conf currently looks like:

# Enable this for template generation
Alias /munin /var/cache/munin/www

# Enable this for cgi-based templates
#Alias /munin-cgi/static /var/cache/munin/www/static
#ScriptAlias /munin-cgi /usr/lib/munin/cgi/munin-cgi-html
#<Location /munin-cgi>
#   Order allow,deny
#   Allow from localhost 127.0.0.0/8 ::1
#   AuthUserFile /etc/munin/munin-htpasswd
#   AuthName "Munin"
#   AuthType Basic
#   require valid-user
#</Location>

<Directory /var/cache/munin/www>
        #Order allow,deny
        #Allow from localhost 127.0.0.0/8 ::1
        Require all granted
        Options FollowSymLinks SymLinksIfOwnerMatch

    # This file can be used as a .htaccess file, or a part of your apache
    # config file.
    #
    # For the .htaccess file option to work the munin www directory
    # (/var/cache/munin/www) must have "AllowOverride all" or something 
    # close to that set.
    #

    # AuthUserFile /etc/munin/munin-htpasswd
    # AuthName "Munin"
    # AuthType Basic
    # require valid-user

    # This next part requires mod_expires to be enabled.
    #

    # Set the default expiration time for files to 5 minutes 10 seconds from
    # their creation (modification) time.  There are probably new files by
    # that time. 
    #

    <IfModule mod_expires.c>
        ExpiresActive On
        ExpiresDefault M310
    </IfModule>

</Directory> 

# Enables fastcgi for munin-cgi-html if present
#<Location /munin-cgi>
#    <IfModule mod_fastcgi.c>
#        SetHandler fastcgi-script
#    </IfModule>
#</Location>

#<Location /munin-cgi/static>
#   SetHandler None
#</Location>

# Enables fastcgi for munin-cgi-graph if present
ScriptAlias /munin-cgi/munin-cgi-graph /usr/lib/munin/cgi/munin-cgi-graph
<Location /munin-cgi/munin-cgi-graph>
    #Order allow,deny
    #Allow from localhost 127.0.0.0/8 ::1
    Require all granted
    # AuthUserFile /etc/munin/munin-htpasswd
    # AuthName "Munin"
    # AuthType Basic
    # require valid-user
    <IfModule mod_fcgid.c>
        SetHandler fcgid-script
    </IfModule>
    <IfModule !mod_fcgid.c>
        SetHandler cgi-script
    </IfModule>
</Location>

ScriptAlias /munin-cgi/munin-cgi-html /usr/lib/munin/cgi/munin-cgi-html
<Location /munin-cgi/munin-cgi-html>
    #Order allow,deny
    #Allow from localhost 127.0.0.0/8 ::1
    Require all granted
    # AuthUserFile /etc/munin/munin-htpasswd
    # AuthName "Munin"
    # AuthType Basic
    # require valid-user
    <IfModule mod_fcgid.c>
        SetHandler fcgid-script
    </IfModule>
    <IfModule !mod_fcgid.c>
        SetHandler cgi-script
    </IfModule>
</Location>
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.