Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I keep getting this error when I try to install Gloobus preview in Natty :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gloobus-preview : Depends: libpoppler7 but it is not installable
E: Broken packages

How do I solve this problem?

share|improve this question
including the error message will help – Joel May 2 '11 at 4:07

Here's the workaround. Note this is a "hack", but it's been tested on multiple systems and doesn't appears to induce any consequences that I'm aware of.

  1. Download a libpoppler7 deb from whatever site you prefer and install it. I've been using libpoppler7_0.14.3-0ubuntu1.2_amd64.deb. No conflicts noted between Natty's installed libpoppler13.

  2. Install gloobus-preview (aptitude install gloobus-preview). I've been using ppa:am-monkeyd/nautilus-elementary-ppa (as he pops open gloobus to reference his logfile ;-) as a repository for both nautilus and gloobus on natty. Can't speak for any other repos.

  3. It will fail installation with a "post.install" message. Read it -- it will tell you where to find the file for the next step (/var/some/thing/or/another/post.installer).

  4. Open the above file in vi and comment out the stanza that references the pixbuffer -- it's the last stanza. Comment out all lines with #'s.

  5. Rerun the installer. sudo aptitude install -f. The installation process should now complete. Press <space> and smile.

I've submitted a bug report on this error and my "hack". No response, but I suspect am-monkeyd is busy with the Elementary OS project just now.

Best, /tom

2011-05-07 22:00 HRS MDT A fix has just been committed to the elementary ppa for the above error: gloobus-preview (0.4.5-ubuntu11~ppa263) Tested and working as advertised.

share|improve this answer
Thanks mate! I'll try – otto May 2 '11 at 6:38
For 32-bit, that package is available at… – Dorkus1218 May 3 '11 at 6:08
Sorry for the above mess -- my mind knows markdown; my fingers are having trouble follow suit. For clarity amongst the above garble: A fix has been committed last night. See above. You can now remove (aptitude purge libpopler7) the "old" libpoppler7 installed as the above hack; no longer required. ammonkey updated gloobus for libpoppler14, which is installed by default on natty. Best, /tom – Tom May 8 '11 at 18:42

Although the above steps are what you will be recommended by goobus-preview of elementary ppa, I kinda got broken package when I tried it with something related to pixbuf. I installed additional libgdk-pixbuf2.0-dev package which doesnot comes as dependency before installing gloobus-preview and all worked fine. You need to search for libpoppler7 as Tom mentions. Here is screenshot

enter image description here

share|improve this answer

I downloaded libpoppler7 from here -, installed gloobus-preview via this ppa -, and didn't do any editing of files after and things worked as they should.

EDIT: I think gloobus-preview was updated as I typed this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.