Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Buffalo headset with microphone that I know works fine becaue I routinely use it on a Windows 7 computer.

It connects to my Ubuntu 13.10 computer fine:

Bluetoth connected

But when I open sound preferences, there is no sound device related to the Buffalo headset (The kenwood is just a USB speaker system):

No bluetooth headset

My computer usually sends audio to a pulseaudio on another machine where the speakers are connected, as per this answer. I had to make an additional tweak to repair an issue with Flash audio, as per this answer. Essentially, I needed to add the following line to my /etc/environment file:

PULSE_SERVER=192.168.0.4:4713

I'm willing to reconfigure any of this if it will allow me to but run use a network audio server, and also get my bluetooth headset to connect.

How do I get my bluetooth headset to work in Ubuntu 13.10?


Requested command line output:

dave@homebase ~ $ pacmd list-modules | grep bluetooth
No PulseAudio daemon running, or not running as session daemon.
dave@homebase ~ $ dpkg -l *bluetooth*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  bluetooth      4.101-0ubunt all          Bluetooth support
ii  cinnamon-bluet 3.8.2+petra  amd64        Gnome Bluetooth support for the C
ii  gir1.2-gnomebl 3.8.1-2ubunt amd64        Introspection data for GnomeBluet
ii  gnome-bluetoot 3.8.1-2ubunt amd64        GNOME Bluetooth tools
ii  indicator-blue 0.0.6+13.10. amd64        System bluetooth indicator.
ii  libbluetooth3: 4.101-0ubunt amd64        Library to use the BlueZ Linux Bl
ii  libgnome-bluet 3.8.1-2ubunt amd64        GNOME Bluetooth tools - support l
ii  libmatebluetoo 1.6.0-2+petr amd64        MATE Bluetooth tools (library)
ii  mate-bluetooth 1.6.0-2+petr amd64        MATE Bluetooth tools
ii  pulseaudio-mod 1:4.0-0ubunt amd64        Bluetooth module for PulseAudio s
dave@homebase ~ $ grep bluetoothd /var/log/syslog
Dec 14 15:57:20 homebase bluetoothd[760]: Unknown command complete for opcode 19
Dec 14 15:57:20 homebase bluetoothd[760]: Adapter /org/bluez/760/hci0 has been enabled
Dec 14 16:24:27 homebase bluetoothd[760]: Discovery session 0x7f5ac1149550 with :1.78 activated
Dec 14 16:25:15 homebase bluetoothd[760]: Stopping discovery
Dec 14 16:25:25 homebase bluetoothd[760]: Stopping discovery
Dec 14 16:25:26 homebase bluetoothd[760]: Stopping discovery
Dec 14 16:25:27 homebase bluetoothd[760]: Badly formated or unrecognized command: AT+CSRSF=1,1,1,1,1,7
Dec 14 17:18:51 homebase bluetoothd[764]: Bluetooth daemon 4.101
Dec 14 17:18:51 homebase bluetoothd[764]: Starting SDP server
Dec 14 17:18:51 homebase bluetoothd[764]: DIS cannot start: GATT is disabled
Dec 14 17:18:51 homebase bluetoothd[764]: Failed to init deviceinfo plugin
Dec 14 17:18:51 homebase bluetoothd[764]: Failed to init proximity plugin
Dec 14 17:18:51 homebase bluetoothd[764]: Failed to init time plugin
Dec 14 17:18:51 homebase bluetoothd[764]: Failed to init alert plugin
Dec 14 17:18:51 homebase bluetoothd[764]: Failed to init thermometer plugin
Dec 14 17:18:52 homebase bluetoothd[764]: Failed to init gatt_example plugin
Dec 14 17:18:52 homebase bluetoothd[764]: Bluetooth Management interface initialized
Dec 14 17:18:52 homebase bluetoothd[764]: Unknown command complete for opcode 19
Dec 14 17:18:52 homebase bluetoothd[764]: Adapter /org/bluez/764/hci0 has been enabled
Dec 14 17:21:06 homebase bluetoothd[764]: Unable to get service record: Host is down (112)
Dec 14 17:21:20 homebase bluetoothd[764]: Badly formated or unrecognized command: AT+CSRSF=1,1,1,1,1,7
Dec 14 18:10:45 homebase bluetoothd[764]: Badly formated or unrecognized command: AT+CSRSF=1,1,1,1,1,7

I have included output from pulseaudio -vvvv on pastebin, and this portion looks like it might be an issue:

E: [pulseaudio] socket-server.c: bind(): Address already in use
E: [pulseaudio] module.c: Failed to load module "module-cli-protocol-unix" (argument: ""): initialization failed.

I can run pavucontrol without issue, so I assumed that means my pulseaudio server was running, however, when I run bt-autoconnect at the command line, I get this output:

bt-autoconnect 1.0.1 scanning: Auto
Unable to run PulseAudio CLI
Failure: Module initialization failed
Pulseaudio module-switch-on-connect loaded
share|improve this question
    
Thank you for the paste. It appears that pulseaudio is able to discover your headset, and to appropriately load it as an audio sink/source. Later however your headset did not respond, hence it was removed from the list of devices. This behaviour is likely to be related to your bluetooth stack, and may come from an incompatible BT adapter, or headset protocol. Also there are faulty entries in the pulseaudio database. Try to delete all ~/.config/pulse and ~/.pulse, then reboot. Also try to remove the headset from Bluetooth devices, to then add and pair it again. Keep fingers crossed! –  Takkat Dec 15 '13 at 8:03
    
Based on your other question: Your pulsaudio server is a network server? (Is that intentional?) If not: Is your pa server running in per-session mode or system-wide mode? What is the output of ps aux | grep pulse? –  falconer Dec 15 '13 at 11:51
    
@DaveMG - remember, having a long conversation in comments makes it hard for others to follow the thread. Please move your comments into your question and delete to clean up. –  fossfreedom Dec 15 '13 at 17:04
    
@falconer - similar comment - please move as much as you can into your answer and clean up by deleting your comments. Thanks. –  fossfreedom Dec 15 '13 at 17:04
    
@falconer: Maybe you didn't see my comment on your answer. The issue has been resolved, and it was your help that got me to the solution. The answer you have below wasn't quite the issue, it was more to do with the pulseaudio issues we covered in chat. I'd like to give you credit for helping me solve the problem, so if you update or edit your answer, I'll mark it correct. Thanks! –  Questioner Dec 17 '13 at 2:50

2 Answers 2

Usually this problem is caused because the headset is configured to use the A2DP profile, which is only one-way (but better quality), so your headset is functioning as a headphone.

You have to switch it to HSP/HFP profile. In the sound settings look under the Output tab, there you will find your headset, and change the profile to Telephony Duplex (HSP/HFP).


But after we did a chat conversation with Dave M G it turned out that his problem was coming from a special network configuration of his pulseaudio services: which is that his sound applications (music players, sound settings, pavucontrol, stc.) were talking directly to the remote pulseaudio server. But the bluetooth daemon on his PC didn't follow suit, it didn't talked to the remote one, instead it tried to connect to the local PA server, which was non existent that time.

When we launched a local PA server in verbose mode it clearly showed that the bluetooth daemon is connecting to the local server, but because every other sound application connected to the remote server there was no sound sent to the local server to hear from the bluetooth headset, and also the BT-headset didn't show up in the sound settings dialogs, because those applications were also manipulating the remote server. After tracing down the problem, Dave M G decided and managed to reconfigure his sound network setup and solve the issue.

share|improve this answer
    
@DaveMG If the headset is not even under the output tab, then your problem is something else. Please post the output of grep bluetoothd /var/log/syslog –  falconer Dec 14 '13 at 9:15
    
Based on our chat yesterday, I was able to solve the issue. I had a line in /etc/environment that solved a problem with Flash audio, which was forcing the Kenwood device to be the only audio device (details added to my question). I've removed that line, and, long story short, I also reversed my server/client relationship, so the computer I'm connecting the BT device to is now the PA server. I would not have traced the problem were it not for our conversation. If you edit your answer just a bit to reflect the solution, I'll mark it correct. :) –  Questioner Dec 16 '13 at 3:29

This worked for me (Using Headset: "Jabra BT8020" and Ubuntu 14.04)

Maybe helpful for other bluetooth headsets as well

In a terminal:

$ pactl load-module module-bluetooth-discover

Source: launchpad: Comment 13 on bug "blueman and pulse's module-bluetooth-discover (A2DP audio sink devices failed to work with "bluetoothd : Unable to select SEP" in system log.)"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.