Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to use upgrade app to upgrade, but the app tell me I can upgrade 13.10 directly. But, if I press upgrade button, then the error message occured like...

An upgrade from 'quantal' to 'saucy' is not supported with this tool.

So, I try to upgrade with terminal by

    sudo do-release-upgrade

but, same error message occured. I using 12.10 now. I want to upgrade to 13.10, but I can't upgrade 13.10, and 13.04.

------add------ I installed ubuntu 12.04 with Windows Installer, and I upgraded this to 12.10.

share|improve this question
1  
Plz keep in mind that op uses wubi. –  Avinash Raj Dec 20 '13 at 1:12
    
This needs a new answer since 12.10 and 13.04 both are EOL by now –  rubo77 Jul 25 at 11:03
1  
@rubo77 This does not need a new answer, since the only change is to use the old-releases archives (askubuntu.com/questions/91815/…) –  muru Jul 25 at 11:27
    
Then maybe you can post that as an answer with instructions how to change it correctly? –  rubo77 Jul 25 at 11:38
    
There are already several answers with instructions in the question that this duplicates –  bain Jul 29 at 23:18

6 Answers 6

First check which versions of update-manager-core are installed:

apt-cache policy update-manager-core

The result may be similar to this...

update-manager-core:
  Installed: 1:0.174.5
  Candidate: 1:0.174.5
  Version table:
 *** 1:0.174.5 0
        500 http://de.archive.ubuntu.com/ubuntu/ quantal-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.174.4 0
        500 http://de.archive.ubuntu.com/ubuntu/ quantal-updates/main amd64 Packages
     1:0.174.3 0
        500 http://de.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages

... which means, that you have installed the package from quantal-proposed

By downgrading to the package from quantal-updates you should be able to upgrade to raring:

apt-get install update-manager-core=1:0.174.4 python3-update-manager=1:0.174.4
do-release-upgrade
share|improve this answer
    
this doesn't solve the problem –  rubo77 Jul 25 at 11:04

I would suggest just installing new version of Ubuntu on this partition from Live CD or USB. It will not erase everything as it could be expected. It leaves home folder - with applications settings and all other stuff like that and which, in my opinion, is the most important - and some application unharmed. As I remember, I tried it upgrading from 13.04 to 14.04 and it worked well.

And before You can always do 1:1 partition copy with GParted. Just in case.

share|improve this answer

Download the meta-release info locally with

mkdir ~/upgrade
cd ~/upgrade
wget http://changelogs.ubuntu.com/meta-release

# change the sources to the old-release arcives:
sed s/archive.ubuntu.com/old-releases.ubuntu.com/ meta-release -i

#enable all releases:
sed 's/Supported: 0/Supported: 1/' meta-release -i

# backup the system meta-release file:
sudo cp -a /etc/update-manager/meta-release etc-update-manager-meta-release.bak

# change the system meta-release path lo the local one on port 80:
sudo sed s/changelogs.ubuntu.com/127.0.0.1/ /etc/update-manager/meta-release -i

# change the LTS info in the same file
sudo sed s/meta-release-lts/meta-release/ /etc/update-manager/meta-release -i

# start serving your own meta-release locally with
sudo python -m SimpleHTTPServer 80

Now start the graphical update-notifier or open a new terminal with Ctrl+Shift+N and perform the release upgrade

sudo do-release-upgrade

Cleaning-up

After the upgrade must restore the system file /etc/update-manager/meta-release

sudo cp -a etc-update-manager-meta-release.bak /etc/update-manager/meta-release 

source: http://askubuntu.com/a/135028/34298

share|improve this answer

I would approach it from this direction:

Take a blank USB, download the Ubuntu version of your choosing, and then from Dash (accessible from the super key unless changed) choose 'Startup disk creator.' Create it to the blank USB, and then restart your computer making sure to enable boot from the USB. Once it booted to the install screen, follow the prompts choosing 'Upgrade to...'

share|improve this answer

I got the same error when trying to upgrade my 12.10 machine. Turns out it was actually caused by the apt-cacher-ng proxy that I use for caching package downloads. The proxy had cached an earlier version of saucy.tar.gz upgrade metadata, which said that upgrade from quantal is not supported.

So as a solution, log in to your proxy machine and run this:

sudo find /var/cache/apt-cacher-ng -name 'saucy.tar.gz*' -delete

If you don't have access to the proxy machine, then just comment out the Proxy line(s) in your /etc/apt/apt.conf

Why was the metadata changed? Because originally the upgrade path was 12.10 -> 13.04 -> 13.10. But support for 13.04 was dropped earlier than 12.10, so the new upgrade path is directly 12.10 -> 13.10. (link)

share|improve this answer

update-manager-core does not currently work for upgrading to saucy (13.10) from quantal (12.10) ..

You need to modify your sources.list manually, and the run ap-get update && apt-get dist-upgrade ..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.