Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm at my wit's end trying to get the latest version of xubuntu to run or install from a USB drive.

Here's what happens:
when I boot from the USB drive, I choose the 'Try Xubuntu' option from the grub menu.
xubuntu starts and I see the splash screen, then a few seconds later the desktop loads...and that's it.
No keyboard or mouse control. I'm using a USB keyboard and mouse, and the light on the mouse doesn't even light up. However, I can tell the OS is not frozen by watching the clock update each minute, and a few notices come and go such as network warnings.

I'm completely stumped. This is a new machine I recently assembled, and I know it works because I installed Windows7 on a spare HD and it runs fine. Also, the BIOS recognizes the keyboard and mouse.

Here's my hardware info:

  • Motherboard - Gigabyte 990FXA-UD5
  • CPU - AMD Sempron 145
  • Video Card - Sapphire Vapor-X R9 270X 2G GDDR5
  • RAM - 2 x 2GB of PC3 12800
  • USB Drive - 16GB Sandisk USB 3.0

As you can see, I'm running fairly new hardware and xubuntu should easily run on this setup. As best I can tell, none of the hardware is faulty, and Windows7 has been running normally for a few days.

Here's what I've done to troubleshoot:

  • swap the RAM
  • swap the video card
  • swap the USB drive
  • boot from a CD install
  • swap the keyboard & mouse
  • try different versions of Ubuntu & Debian
  • experiment with UEFI and non-UEFI options

When trying different versions of Linux, I have used the net install and full install and tried to proceed from there. But every time I get stuck on the 'choose a language' screen, which seems odd.

It's almost as if xubuntu (and others) are not seeing my keyboard or mouse correctly. But the BIOS and Windows recognize both without issue.

Does anyone have any ideas on what I can try next? Save me from Windows!

share|improve this question
    
Might be worth looking for a option saying legacy usb in the bios and enable it. What version of Xubuntu are you trying? What brand and model is your mouse and keyboard? –  Anders F. U. Kiær Dec 16 '13 at 18:19
    
I've tried xubuntu 13.10, Ubuntu 12.10, and the latest stable Debian. I just have a generic USB keyboard, but I've also tried my Mac keyboard (the latest one) and I have a Logitech RazorX USB mouse. The strange thing is that no version of Linux seems to recognize either. On a net install of Debian, I get to the 'select a language' screen and the keyboard and mouse stop working. –  user225266 Dec 16 '13 at 23:01
    
Did you look into this? Might be worth looking for a option saying legacy usb in the bios and enable it. –  Anders F. U. Kiær Dec 17 '13 at 0:07
    
Thanks. I finally found the fix for this. In the BIOS, set IOMMU to "Enabled". This solved the USB issue and enabled the ethernet port. –  user225266 Dec 18 '13 at 3:37
    
I got the exact same issue and try many things. Your IOMMU suggestion solve the issue with the mouse and keyboard. THank you user225266 –  javqui Jan 8 at 6:21

protected by Community Jan 19 at 12:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.