Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please note: I'm a newbie with Ubuntu, only just beginning to get a grasp on terminal, etc.

Whenever I try to install anything using terminal, with

sudo apt-get install vlc

it works fine untill I have confirmed additional disk space will be used.

After it has fetched all the necessary files and unpacked them, I get a long list starting with

dpkg: error processing [...]

And it ends with

Processing was halted because there weE: Sub-process /usr/bin/dpkg returned an 
errorcode (1)

I already googled for a solution quite a bit but can't find anyone with the exact same issue.

Also, I don't know if it has anything to do with it, but I tried to get some additional plugins for an application I installed through software center and it gave me an error message saying

"An unhandlable error occured: There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks."

Thanks in advance.

Edit: here's the full error log: http://pastebin.com/9YJSrf4a

share|improve this question
    
plz post the full error report. –  Avinash Raj Dec 13 '13 at 16:34
    
Try this sudo dpkg-reconfigure -a, and report back. This may take a long time. –  Mitch Dec 13 '13 at 16:45
    
Avinash, I put the error log in the comments Mitch, I did what you said and it gave me back /usr/sbin/dpkg-reconfigure: ca-certificates is broken or not fully installed –  user225138 Dec 13 '13 at 19:22

1 Answer 1

Run

sudo dpkg --purge ca-certificates

Then run :

sudo dpkg-reconfigure -a

If yet not solved :

Run

gksudo gedit /var/lib/dpkg/status

In the resulting text document, search for the sections start with Package : ca-certificates. Then delete the whole section starts with that.

Then run

sudo dpkg-reconfigure -a && sudo apt-get update
share|improve this answer
    
Computer says:dpkg: error processing package ca-certificates (--purge): dependency problems - not removing Errors were encountered while processing: ca-certificates –  Emanuel Landeholm Jul 22 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.