Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.04 yesterday using the Wubi installer and I've noticed that a few of my programs will disappear when I minimize them. For example, I can't minimize Eclipse because it will disappear and I won't be able the load a 2nd one because the 1st is using my workspace (if you're familiar with Eclipse you know that you can't use the same workplace twice as the same time). I also just noticed that if I minimize a terminal then it will disappear as well.

Does anyone have any idea why this is happening and what, if anything, I can do to prevent it?

share|improve this question

migrated from unix.stackexchange.com May 1 '11 at 23:17

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems..

1  
When you say disappear, you mean its icon also vanishes from the launcher? –  RolandiXor May 1 '11 at 23:21
    
Unless I have ticked off the box that keeps the icon in the launcher after I close the program, yes. If I do have this box ticked then clicking the launcher icon will load another instance of the program. –  brewer2 May 2 '11 at 0:30
    
Just happened to me on Ubuntu 13.04: Netbeans 7.3 simply disappeared after minimizing! (of course it was also missing from Alt-Tab: it's not that simple, Peter). Even more weird: the Netbeans icon locked to the Unity Dock bar was now launching Gedit... Could not find any other solution than restart, after which everything went back to normal: minimizing, alt-tab and the Dock icon of Netbeans was working again - but I don't trust this #&@# Unity anymore, I also installed Avant Windows Navigator just in case. I love the features of Ubuntu 13.04, but Windows 7 was much more reliable on the sa –  Henrik Tóth May 8 '13 at 20:49

9 Answers 9

I fixed my 64-bit Ubuntu system by adding an applet for Avant Windows Navigator called Launcher/taskmanager. Now every time I shrink a window it appears on the AWN bar.

share|improve this answer

I had this same issue as well, but for me it was solved by taking AllTray out of the equation. You didn't happen to have the programs set to automatically minimize to the system tray, did you? If you did, the tray requires the applications to be white-listed now.

Instead of just denying it, it seems to just hide the program completely. Almost as if alltray was doing it's job, but being denied an icon spot in the tray.

share|improve this answer

I found a solution...it only works in the Ubuntu Unity interface and NOT Classic...I used the first solution listed: http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html

share|improve this answer

There is no need for any of that - simple ALT-TAB and when you get to your App you'll see all the open screens - just tab to the one you want. Ok, it could be easier...

share|improve this answer

In Eclipse, I went to Windows --> Preferences. In the General tab I selected Always run background. It would not surprise me if something similar worked in other programs.

share|improve this answer

For me this worked: pressing Command + w (or Windows + w) pops up the running programs, including the minimized ones that I can't access with alt+tab.

share|improve this answer
1  
Host+W? What is the "Host" here? Do you mean Super/Windows/Meta key perhaps? –  gertvdijk Jun 27 '13 at 12:40
    
yes that's what I ment. I changed the answer. –  joepadmiraal Jul 1 '13 at 14:22

Just change the login screen to Ubuntu Classic, after you login there is a small icon in the left bottom (bottom panel), right click near the icon go to preferences, select show windows from all work spaces.
That's it, you will be able to view the minimized windows :)

share|improve this answer

I used to have a similar problem in 12.04, with workspaces - windows would (seemingly randomly) disappear, and it would turn out that they were in a different workspace. The standard Alt+Tab combination is designed to only take windows from the currently active workspace.

There are a couple of ways you can see if this is the case:

  1. Open up the workspace switcher, and see if the missing windows are there. From the switcher (in 12.04; I don't know whether the behaviour is the same in 11.04) you can drag any open windows into the desired workspace.
  2. Use Ctrl+Alt+Tab instead of just Alt+Tab. This will switch between windows in all workspaces, not just the active one.

If you want a more permanent solution (indeed, if this is what's happening) and don't use multiple workspaces, you can disable the extras using e.g. Ubuntu Tweak (sudo apt-get install ubuntu-tweak) - under Tweaks->Workspace, set the "Horizontal workspace" and "Vertical workspace" settings to 1 each.

share|improve this answer

Right click on panel - select add to panel - scroll down and chose windows list all file minimize - will show on panel.

share|improve this answer
1  
I cannot grok this assemblage of words ; perhaps edit? –  belacq Jul 10 '13 at 15:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.