Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I do not find an option to change the window behaviour that was in Appearance Properties.

In particular I find it very annoying that Nautilus is always maximised when opening it.

Is there a way to change that default behavior?

share|improve this question
    
Have you tried using Compiz to do this? –  Alan May 1 '11 at 23:22
    
@Alan: Do you have a suggestion where I should look in ccsm? I do not see it immediately –  joris May 2 '11 at 7:42
    
I posted an answer. It works in Ubuntu Classic, but I'm not sure if Unity by default will override it. Hope it all works out for you! –  Alan May 2 '11 at 16:40

5 Answers 5

up vote 4 down vote accepted

The window is maximized if it is started with a size over 75% of the display.
You can unmaximize hitting the button or double clicking the title.
Note that there is a bug in this behavior, not all windows respecting that.

Why do firefox 4 and evolution always open maximized in Unity?

https://bugs.launchpad.net/unity/+bug/754214

I'm at mobile so I wiil fix the layout when I get home.

share|improve this answer
    
OK, but that's for the Dash. And I have set the form-factor on 'Desktop' so my dash is not maximised anymore, but Nautilus still is every time I open it. –  joris May 2 '11 at 7:39
    
I'm sorry I didn't pay attention. I think this can help askubuntu.com/questions/35011/… I'm at mobile right now, I will fix the answer when I get home. –  desgua May 2 '11 at 11:16
    
There is a bug for something like that: bugs.launchpad.net/unity/+bug/754214 –  desgua May 2 '11 at 11:21
    
It has to do with the 75%-rule. When I close nautilus windowed, but smaller so under the 75%, then it also opens windowed. Previously I closed Nautilus not small enough so it opened maximised again. Thanks! –  joris May 2 '11 at 11:46
    
Is there a way to change that number of 75%? –  joris May 2 '11 at 11:47

In 11.04, when Unity is the default for desktops as well as netbooks, this behaviour will be set based on screen size by default, but also customizable in Appearance Properties. You will be able to let the system decide, or configure it always to maximise (except blacklisted apps) or never to maximise.

share|improve this answer
    
I'm running 11.04 and getting annoyed with Firefox always starting maximised. I can't find this setting in Appearance Properties. Did it end up being set somewhere else? –  David Dean Apr 20 '11 at 10:24
  • Install CompizConfig Settings Manager.

    sudo apt-get install compizconfig-settings-manager
    
  • Launch it by searching from the dash in Unity, or Preferences > CompizConfig Settings Manager in Ubuntu Classic

  • Navigate to the Place Windows tabenter image description here

  • Adjust Placement Mode to your liking.enter image description here

share|improve this answer
    
Thanks for the answer! However, it does not change the 75% rule. So I will just ensure that I set nautilus just under 75% of the screen so it is not maximised when I open it again. –  joris May 8 '11 at 10:52
    
I'm sorry it didn't work. I mainly use Ubuntu Classic, so most of what I post for Unity is done with a grain of salt. –  Alan May 8 '11 at 16:31

I can't comment because my OpenID is broken so I can't log in as a privileged user, but (at least on 11.10) you can address the 75% rule in Compiz, too: it is currently under Desktop > Ubuntu Unity Plugin > Experimental

Set this value to 100% and all windows should open at their previous size.

share|improve this answer

10.10

That seems to be the wanted behaviour, according to this bug:

That's wanted. Unity in maverick is the netbook edition, made for small screen. So, all applications are maximized by default.

I guess you will have to wait until the Desktop version of Unity is released, which will happen "as soon as possible".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.