Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed on my laptop Windows 8.1 without SecureBoot. After that I installed Ubuntu 13.10 and created partion /boot/efi and now laptop starts only ubuntu. How can I change grub settings to choose what OS will be started Ubuntu or Windows?

share|improve this question
1  
You should only have one efi partition per hard drive. You can try copying all files from Ubuntu efi partition to original efi partition and with gparted set original efi partition as only boot partition. Both Windows & Ubuntu should have separate folders with boot files in one efi partition. Or delete second efi partition, set boot on first efi partition and reinstall grub with Boot-Repair. help.ubuntu.com/community/Boot-Repair –  oldfred Dec 13 '13 at 1:31
    
Please run the Boot Info Script, post the RESULTS.txt file that it generates to a pastebin site, and post the pastebin URL for the document here. (Alternatively, you could post the URL that Boot Repair spits out, but I'd recommend not running Boot Repair without more information.) Without that information, any answer will be based on assumptions. –  Rod Smith Dec 13 '13 at 20:26
    
Result of boot info script execution here pastebin.com/ALWKtrAe I tried Boot Repair but it didn't help me. –  Dmitro Dec 15 '13 at 22:33
add comment

1 Answer 1

There's no evidence of a Windows boot loader on your hard disk. I recommend you run a Windows recovery tool and tell it to re-install the Windows boot loader. Unfortunately, I can't be more precise about that because I'm not very familiar with the relevant tools. The result is likely to be that the computer will boot straight to Windows. You'll then need to open an Administrator Command Prompt window and type the following command:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

This should set GRUB as the default boot loader. (If Secure Boot is active or if you think you might want to activate it, substitute shimx64.efi for grubx64.efi in that command.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.