This question already has an answer here:
When i go to install gcc 4.8 using:
sudo apt-get update sudo apt-get install gcc-4.8 g++-4.8
I get the error message:
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies. gcc-4.8 : Depends: binutils (>= 220.127.116.1131017) but 18.104.22.16830913-0ubuntu1 is to be installed E: Unable to correct problems, you have held broken packages.
Anyone please help?
EDIT: I tried this but it didnt work:
sudo apt-get clean sudo apt-get update apt-get upgrade -f
EDIT2: Just done fresh install on a second machine. Did exactly the same and encountered the same problem. However, when I check the version number for gcc (and g++) it says 4.8.1 !?!?!