Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed ubuntu on my new Acer Aspire v5-123 laptop, after using it with great satisfaction for years on two other laptops.

First I got the more common problem of the display manager not starting, but I solved that by installing the proprietary driver.

But now I have the problem that every time I close my laptop screen or plug in the HDMI cable or do something else that make the screen goes black, it won't turn on anymore. So when I close the screen, and re-open it it does not reactivate, it remains black nothing to be done about it. The computer also doesn't goes into stand-by as the power button light remains on. I tried CTRL-ALT F2 etc. to reactivate, but no help. The only thing I can do in such situations is hold the Power button for five seconds en restart.

I try to focus to first put the computer in stand-by before closing the screen, but I quite regularly forget and that means that I am always obligated to shut down by holding the power button for five seconds, and to be honest it irritates the hell out of me, and it can't be good for my computer to do that all the time.

If there is anyone who recognises this problem or has any solution, that would be very much appreciated and very helpful. Thanks in advance!

share|improve this question
up vote 0 down vote accepted

I found the solution myself, with the help of the topic shown by Kaleb, however it was hidden in the comments there instead of a solution.

Simply doing:

sudo apt-get install acpi

in the terminal solved the problem completely.

share|improve this answer
Still it is weird that it solves the problem because if you look what the program acpi does it seems like that has nothing to do with the problem. However I am glad it solved the problem. But I am still curious why this solves the problem. – Johan Dec 29 '13 at 11:23

this is an identical issue with a different acer laptop i would recommend also watching the answers to this thread.

or you can change this:


or this:

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

in the file /etc/default/grub, then:

sudo update-grub

now you can adjust the brightness with hotkeys; still can't turn on the screen yet.

share|improve this answer
It was not identical, but it did however led me to the solution. I do not really see what is the use of your tip if that does not reactivate the screen. I by the way never had problems with adjusting the screen brightness with the hotkeys. The problem was that the screen was really off. Since it led me to the solution i still thank you for your answer. – Johan Dec 29 '13 at 11:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.