Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, what do I have:

  • Acer Aspire V30772G laptop with an Intel video-chipset and an Nvidia Geforce GT 750M video-card
  • Ubuntu 12.04 installed and updated, with the proprietary driver selected (nvidia-319-updates)

What's the problem?

  1. OpenGL doesn't seem to be working properly. glxinfo | grep OpenGL sais OpenGL is enabled, but it's software-rendered, so it does not allow the unity 3D features to activate.

    OpenGL vendor string: VMware, Inc. OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits) OpenGL version string: 2.1 Mesa 9.2.0 OpenGL shading language version string: 1.30 OpenGL extensions:

  2. Thus Compiz is not working properly, especially when I try to configure the virtual workspaces or navigate between them (it only shows an icon of the topmost application instead of a full view).

What I have already tried.

  1. I have tried installing bumblebee, did not help.
  2. I have tried installing the nvidia 331 driver from source. Nothing.
  3. Tried installing the same nvidia-331 driver from xorg-edgers, it did not change the problem, but after I ran apt-get upgrade I was unable to log in after reboot (the xorg got broken).
  4. Tried the answer below with purging and reinstalling the nvidia drivers. It brought me to the output mentioned above, but still does not work as I need.

Unity 3D test

OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)
OpenGL version string:  2.1 Mesa 9.2.0

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no
share|improve this question
    
Maybe poor ettiquet by me, but i thought maybe this would help. I couldn't get unity 3D to show due to opengl error so maybe this wil help: askubuntu.com/questions/388483/… –  Nkciy84 Dec 14 '13 at 12:15
    
Oh. The problem is indeed in Unity 3D not working and kicking back to Unity 2D. –  Almaron Dec 14 '13 at 12:27
    
Did you reboot? What is the output of /usr/lib/nux/unity_support_test -p? Is the unity 3D option missing completely at the login screen or do you just fallback to 2D after selecting 3d? –  Nkciy84 Dec 14 '13 at 17:04
    
@Nkciy84 yes, I did. After that the Glx went on, instead of throwing errors, but Unity is still 2D. Give me a minute and I'll update the question with the output you requested. –  Almaron Dec 14 '13 at 18:38
    
@Nkciy84 updated the post. I try to load in Ubuntu (not in Ubuntu 2D) and it still falls back to 2D. –  Almaron Dec 14 '13 at 18:43
show 2 more comments

1 Answer

  • Open your terminal ctrl+alt+T (if you are in GUI that is. From CLI first make sure you have a working internet connection. Offcourse there is no need in CLI to open up any terminal)

Type or copy/paste each line:

  • sudo apt-get purge nvidia*
    This will remove your current nVidia drivers (using the one provided below gives a much more stable response)
  • sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
  • sudo dpkg-reconfigure xserver-xorg
    The above two lines should fix Xorg
  • sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf

After this reïnstall nVidia software

  • sudo apt-add-repository ppa:xorg-edgers/ppa
    This provides the necessary repository (assuming you removed it)
  • sudo apt-get update
  • sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319
share|improve this answer
    
Wouldn't that crush my xserver? I thought the xserver-xorg package was different in the LTS version and called something like xserver-xorg-lts-precise. And secondly: would it be better to install the latest nvidia-331 drivers instead? –  Almaron Dec 14 '13 at 13:20
    
I am using 12.04 and it is what worked for me. I don't want to come across as being lame, but if you have a fresh install there is not much to loose if you try. As to your question about nVidia driver, this is to date the one that works the best for me. If you don't want to take my suggestions an are afraid it wil downgrade or break anything then please don't try anything and wait for better answers. I am by no way a Guru in ubuntu and my knowledge is limited. I must acknowledge this. –  Nkciy84 Dec 14 '13 at 13:24
    
Problem is I have already installed everything I need for work and not having GLX only affects the looks (Unity 2D instead of 3D being active). So there's quite a thing)) But thanks alot anyway, this is the most promissing answer I got so far. –  Almaron Dec 14 '13 at 13:31
    
did not work as I expected. OpenGL seems to be on now, but unity 3D is still not working. Updated the post. –  Almaron Dec 14 '13 at 16:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.