Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My os is ubuntu 13.10, I use the following code to remove the kde desktop installed before:

  sudo apt-get purge kde*

And then use the following code to install gnome 3.10:

  sudo add-apt-repository ppa:gnome3-team/gnome3-next && sudo apt-get update
  sudo apt-get update && sudo apt-get install gnome-shell ubuntu-gnome-desktop
  sudo add-apt-repository ppa:gnome3-team/gnome3-staging
  sudo add-apt-repository ppa:gnome3-team/gnome3
  sudo apt-get update && sudo apt-get dist-upgrade

After all these were done, I restart my computer and can not find my cursor in Unity while all things are ok in Gnome. I want to find the cursor in Unity, what should I do? Any help or suggestions will be appreciated!

share|improve this question
    
This seems to be a known problem of installing GNOME 13.10. Please have a look at this: askubuntu.com/a/381832/154414 –  cshubhamrao Apr 19 at 7:48

2 Answers 2

up vote 4 down vote accepted
+50

Try this, it works for almost all people I could find:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Source: the bugzilla entry of this bug: 694758

From the bug entry, what I could conclude, this command works because it disables the cursor plugin of the gnome-settings-daemon. Quoting Comment 14 of the bug:

(...) looks like mouse pointer plugin is failing to reactivate pointer (anyway, I don't fully understand why the pointer is made hidden when devices like a touchpad are available and no touchscreen one is present)

From Gentoo's GNOME 3.8 Upgrade Guide's Troubleshooting section:

(...) This [command] will prevent the mouse pointer to become invisible and not come back even not running a touchscreen.

Just for a liitle more knowledge, this is not a GNOME bug, Quoting Comment 18 (from the same bug report):

There were bugs in the XSync protocol (used to determine which input device was used last) and in the QXL driver that didn't show a cursor in some cases. (...)

Launchpad bug LP#1238410 confirms it.

share|improve this answer
    
Can you explain why this works? –  Eden Harder Apr 19 at 9:49
    
@EdenHarder please see the Updated answer. I should have added the explanation and the sources much before as you wanted answer from credible and/or official sources. My fault. –  cshubhamrao Apr 20 at 10:34

try this :

sudo apt-get install unity-desktop && sudo apt-get install unity

then remove what you have installed before by -

sudo add-apt-repository--remove ppa:gnome3-team/gnome3-next
sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get purge gnome-shell
sudo apt-get purge gnome-documents gnome-contacts epiphany-browser gnome-boxes gnome-shell-extensions gnome-tweak-tool bijiben gnome-clocks
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo reboot

hope it helped you.

share|improve this answer
    
Thanks! I have tried this method but not help. –  Eden Harder Apr 19 at 9:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.