Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 11.04 a few days ago and the first few boots unity loaded as expected. But now its just booting into GDM.

I did get one popup about it not being supported on my machine (After the it had booted fine 2 or 3 times!) but i dismissed it without reading it.

I've looked at How can I activate Unity? but nothing shows up in my additional drivers except for a wireless chip

the dropdown at login has ubuntu, ubuntu classic and ubuntu classic safe mode i think

share|improve this question
    
Try removeing any graphics drivers you have and installing them again –  Uri Herrera May 1 '11 at 21:25
    
What happens when you select "Ubuntu" and login? –  RolandiXor May 1 '11 at 21:38
    
@Uri how do i remove them? there is nothing in additional drivers @Roland i get gdm –  Bruce Aldridge May 1 '11 at 22:06
1  
sudo apt-get --purge remove nvidia-* if you have nvidia graphics, sudo apt-get remove fglrx if you have amd/ati graphics –  Uri Herrera May 1 '11 at 22:13
    
@Uri purging them worked a treat, haven't re-installed but still seems to work –  Bruce Aldridge May 2 '11 at 7:45

1 Answer 1

up vote 1 down vote accepted

Remove any Drivers that may be causing the issue:

  sudo apt-get --purge remove nvidia-* if you have nvidia graphics, 
  sudo apt-get remove fglrx if you have amd/ati graphics

to get any of them back:

If your system architecture is 64bit (x86_64), you need the ia32-libs package as well.

  sudo apt-get install ia32-libs

then for both 32 and 64bit:

  sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
  sudo apt-get update
  sudo apt-get install nvidia-current nvidia-settings

and for ATI

  wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-4-x86.x86_64.run

Once dowloaded right-click the .run file and set it to run as executable.

  sudo apt-get remove --purge xserver-xorg-video-radeon

that will remove the opensource radeonHD driver.

Now this is only if it's a 64bit system:

  cd/path_of_the_file       

  sh ati-driver-installer-11-3-x86.x86_64.run --buildpkg Ubuntu/natty

  sudo dpkg -i fglrx*.deb

  sudo aticonfig --initial -f

For the 32bit system just run the ati installer.

share|improve this answer
    
actually i've just had two nasty crashes of unity/gdm in the past 15mins, i'm guessing its related.. how do i reinstall those drivers? I've tried nvidia-{173,96}-modaliases and nvidia-{96,173} and i get the error ` nvidia-173 : Depends: xorg-video-abi-10 Depends: xserver-xorg-core (>= 2:1.10.0-0ubuntu1~) but it is not going to be installed nvidia-96 : Depends: xorg-video-abi-8.0 but it is not installable Depends: xserver-xorg-core (>= 2:1.8.99.905-1ubuntu3) but it is not going to be installed ` –  Bruce Aldridge May 2 '11 at 21:32
    
... theres my problem ... its not nvidia –  Bruce Aldridge May 2 '11 at 21:42
1  
added more info. to know which hardware you have to open a terminal and type hardinfo, install it if you don't have it already. –  Uri Herrera May 3 '11 at 3:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.