Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have huge SXSW compilation albums. They clutter Artists view. Clementine has an elegant solution for this — compilations are stored under Various Artists. How can I solve this in Banshee?


share|improve this question
I filed this as bug two years ago, it was already filed as bug 4 years ago and the developers don't care. I am not sure whether they just don't understand the problem or they are too agitated with new features. I gave up hope and use guayadeque for the moment. – piedro May 1 '11 at 20:34
Sry, you google "banshee albumartist browser view" you should get some threads on it ... – piedro May 1 '11 at 20:35
@piedro: I was wondering about this, why don't they just fix it, you know? – RolandiXor May 1 '11 at 20:44
@piedro can you give a link to your bug report, please. Gonna do some raging in comment section. – skfd May 1 '11 at 21:07
To be honest, I don't find my own reports anymore, don't know why, just found my rhythmbox stuff. And a lot of entries in various forums. But you may look at these (there's hope):… – piedro May 1 '11 at 21:56
up vote 4 down vote accepted

Select your songs using shift+click then left click, choose edit track information, and choose "Various artists" for your songs. Then click the icon next to the artist.


Keep in mind, if you have the option to save metadata to files enabled, that your files will have "Various Artists" as the artists! So disable this option in preferences (unless this is what you want).

enter image description here

share|improve this answer
Roland's answer is in fact correct. I just did not get this immediately — I thought it would wipe Artist field. It actually writes data into Album artist field. Нowever, I think Various Artists problem needs a better solution. You can find reasoning for that in comment by @piedro above. I reported this as an [explicit bug][1], just to be sure request is documented. – skfd May 3 '11 at 20:58
@skd: I agree, this bug needs to be sorted, I am similarly bothered by it :P – RolandiXor May 3 '11 at 22:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.